LZDoom Software DL not affecting player sprites

Discuss anything ZDoom-related that doesn't fall into one of the other categories.

LZDoom Software DL not affecting player sprites

Postby MartinV » Mon Nov 08, 2021 6:31 pm

Hello friends! (First time posting, I think this is the right board, if not please move)

Been a lurker on the ZDoom forums for years, but the one question I have yet to see posted, is about LZDoom's Software Renderer's dynamic lights not affecting the player's sprite, (I.E weapons), so made this account to ask this question. Is there something I'm missing, or is it simply a feature that isn't possible? I know the lighting affects all other sprites, such as monsters and projectiles, but not the Player's POV sprite. Mainly looking to see if this is something that's in another build or isn't possible, as I want to make Doom videos, but my laptop and OBS don't agree recording while in OPENGL, plus the aesthetics of software appeal more to me.

The issue is most present in wads that rely on dynamic lighting, such as the Lasting Light mod (See image) which is completely dark, aside from the lantern light, however the experience is broken in software as your arm and lantern are not illuminated but the environment and Enemy sprites are.

Is there a build that does what I'm looking for?
You do not have the required permissions to view the files attached to this post.
MartinV
 
Joined: 08 Nov 2021
Discord: Martin_Verum#0425
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom Software DL not affecting player sprites

Postby Rachael » Tue Nov 09, 2021 12:49 am

Try GZDoom with SoftPoly, it will support software rendering and will likely fix this problem.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: LZDoom Software DL not affecting player sprites

Postby MartinV » Tue Nov 09, 2021 3:29 am

Rachael wrote:Try GZDoom with SoftPoly, it will support software rendering and will likely fix this problem.



Unfortunately, my laptop does not agree with GZDoom very well. I can't seem to fix the 35 fps it's stuck in, even with most advanced settings turned off and resolution set to 320x200.

I'm guessing Im out of luck on this front? :(
MartinV
 
Joined: 08 Nov 2021
Discord: Martin_Verum#0425
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Legacy GZDoom)


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest