Page 1 of 1

[Solved] Which doom2.wad should I use?

PostPosted: Thu Aug 26, 2021 2:05 am
by Sander Bouwhuis
I looked at the wiki and was wondering if someone could help me.

In the wiki it says there are multiple versions of doom2.wad I can use. I have the Doom 3 BFG edition on Steam in the E:\Games\Steam\steamapps\common\DOOM 3 BFG Edition\base\wads directory. So, I copied the DOOM.WAD, DOOM2.WAD and NEVER.WAD files to the GZDoom\Iwad directory.
But, it says that other versions have bugs fixed. I also read in a Doom 3 BFG review that the doom2.wad in this version was censored.

Can someone give me information on which doom2.wad is the complete/uncensored/best version?

Re: Which doom2.wad should I use?

PostPosted: Thu Aug 26, 2021 2:09 pm
by axredneck
Usually these are preferred versions if i'm not mistaken:
https://store.steampowered.com/sub/18397/
But you can still use BFG edition, it is compatible with mods.

Re: Which doom2.wad should I use?

PostPosted: Fri Aug 27, 2021 1:09 am
by Sander Bouwhuis
Aaaaaah, shoot. Then I bought the wrong game. I don't even like Doom 3... I just bought it for Doom 1+2 wads.

Anyone have a different opinion on which wads to get for the 'best' experience?

Re: Which doom2.wad should I use?

PostPosted: Fri Aug 27, 2021 8:45 am
by wildweasel
The BFG WADs will still function if you're loading mods over them. The Wolfenstein level censorship doesn't affect 99.9% of levels, since it's generally discouraged to use the Wolfenstein textures or enemies in levels without modifying them first, and there's a mod you can load that restores the medikits.

Re: Which doom2.wad should I use?

PostPosted: Sat Aug 28, 2021 9:21 pm
by leileilol
just don't use the french one

Re: Which doom2.wad should I use?

PostPosted: Sun Aug 29, 2021 1:13 am
by Sander Bouwhuis
wildweasel wrote:The BFG WADs will still function if you're loading mods over them. The Wolfenstein level censorship doesn't affect 99.9% of levels, since it's generally discouraged to use the Wolfenstein textures or enemies in levels without modifying them first, and there's a mod you can load that restores the medikits.

Thanks for the info guys/gals!

Can you tell me which mod to use to fix my wads?
Or is there a patch so that I can convert my wads to fix them?

Re: Which doom2.wad should I use?

PostPosted: Sun Aug 29, 2021 4:54 am
by Gez
There are patch tools that can convert any version of the Doom II IWAD nearly into any other version.
http://doomgate.de/files/duub/index.html


So you can take your BFG IWADs and turn them into the regular versions.

Re: Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 3:37 pm
by Hunterj1234
Gez wrote:There are patch tools that can convert any version of the Doom II IWAD nearly into any other version.
http://doomgate.de/files/duub/index.html


So you can take your BFG IWADs and turn them into the regular versions.

Is this even legal? it seems like it imports unmodified assets into a wad, i think tha this is in the gray area lik romhacks

Re: [Solved] Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 4:26 pm
by wildweasel
It contains only the changes, so it cannot be used to construct a full version from nothing.

Re: [Solved] Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 4:35 pm
by Hunterj1234
wildweasel wrote:It contains only the changes, so it cannot be used to construct a full version from nothing.

I don't know, man, it contains unmodified doom2.wad resources. i guess id software isn't like nintendo

Re: [Solved] Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 4:40 pm
by wildweasel
Hunterj1234 wrote:
wildweasel wrote:It contains only the changes, so it cannot be used to construct a full version from nothing.

I don't know, man, it contains unmodified doom2.wad resources. i guess id software isn't like nintendo

It's been said multiple times in the past, Doom resources are fine to distribute and use in mods as long as the resulting file requires Doom to run.

Re: [Solved] Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 5:02 pm
by axredneck
wildweasel wrote:... as long as the resulting file requires Doom to run.

But what if it works with FreeDoom?

Re: [Solved] Which doom2.wad should I use?

PostPosted: Mon Aug 30, 2021 5:10 pm
by wildweasel
axredneck wrote:
wildweasel wrote:... as long as the resulting file requires Doom to run.

But what if it works with FreeDoom?

If these are the patches that I believe they are, they check for a valid Doom by its hash, which Freedoom generally will not match.

Re: [Solved] Which doom2.wad should I use?

PostPosted: Tue Aug 31, 2021 2:53 am
by Gez
axredneck wrote:But what if it works with FreeDoom?


They're not going to work with Freedoom. And if you somehow force them to apply to Freedoom, the results will be... interesting... but certainly not playable.


Alright, so what's a diff patch and how does it work? It only contains the differences, at a binary level, between one file and another. So you compare file A with file B, and it gives you patch C. Then if you have file A and you apply patch C to it, you get file B. But if you have file D and you apply patch C to it, you get complete garbage.

Do not expect that you could open the patch with something like SLADE to look at the assets therein. There are no assets at all. It's not a PWAD, it's a low-level byte-by-byte difference.

It's actually similar to cryptography. Suppose you have this sentence:
Code: Select allExpand view
The five boxing wizards jump quickly.

And you want to "patch" it into:
Code: Select allExpand view
Jackdaws love my big sphinx of quartz.

The "patch" may end up being something like:
Code: Select allExpand view
CHGPLVATZLDRSUJHGJSZRHJDVKCCBEX


Same principle here, the patch is apparently random noise that only ends up making sense after being applied to the correct source file. If you apply it against something else, you end up with something unusable.

Re: [Solved] Which doom2.wad should I use?

PostPosted: Tue Aug 31, 2021 6:06 am
by axredneck
I mean mods, not your patches. Mods which use Doom lumps but work with FreeDoom (almost all mods work with it)