KDiZD fails to launch.

Discuss anything ZDoom-related that doesn't fall into one of the other categories.
yum13241
Posts: 227
Joined: Mon May 10, 2021 8:08 pm
Discord: yum13241#8226
Github ID: yum13241
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Modern GZDoom)

KDiZD fails to launch.

Post by yum13241 »

I use DOOM.WAD as the IWAD and load kdizd.pk3 as the PWAD and lo and behold, I get a Fatal Error which says:
Script error, "kdizd.pk3:decorate/decorations.txt" line 996:
SC_GetFloat: Bad numeric constant "0.4´".

IK this is a mod problem, but what am I supposed to do? I have zero DECORATE experience, and I can't wait forever.
User avatar
wildweasel
Moderator Team Lead
Posts: 21378
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: KDiZD fails to launch.

Post by wildweasel »

Open the PK3 using a program like SLADE, find decorations.txt in the Decorate folder, and delete the extra ` mark after 0.4 on line 996.

Or make sure that you have the ABSOLUTE NEWEST version of KDIZD, as I'm halfway sure that bug is already fixed on their end.
yum13241
Posts: 227
Joined: Mon May 10, 2021 8:08 pm
Discord: yum13241#8226
Github ID: yum13241
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Modern GZDoom)

Re: KDiZD fails to launch.

Post by yum13241 »

wildweasel wrote:Open the PK3 using a program like SLADE, find decorations.txt in the Decorate folder, and delete the extra ` mark after 0.4 on line 996.

Or make sure that you have the ABSOLUTE NEWEST version of KDIZD, as I'm halfway sure that bug is already fixed on their end.
Did the second option, and it worked! Thanks! Intro felt like a movie...

Return to “General”