Automap display in the latest GZDoom.

Discuss anything ZDoom-related that doesn't fall into one of the other categories.

Automap display in the latest GZDoom.

Postby caiusmisus » Thu Nov 26, 2020 8:59 am

EDIT:
Sorry, this is a duplicate of a thread I already made earlier. I was having some issues with logging in and thought at first that it wasn't created. It lacked the screenshots and more details so here it is again.
END OF EDIT

So, after a long break, I came back to do some dooming. Last I used was ZDoom 2.7.1. Tried the latest GZDoom and am liking what I'm seeing like a built-in option to disable transparency, more compatibility options etc.

I went about setting up the way I wanted and got almost everything. Except one thing... The automap just looks strange. I went with the classic Doom look, but even then, the colors seems washed out. Previously in Zdoom, the lines were a bright color and perfectly visible (see screenshots).
ZDoom automap screen: https://pasteboard.co/JCa1T5am.png
GZDoom automap screen: https://pasteboard.co/JCa2A6Z.png

The lines also shimmer strangely when I am moving with automap open in GZDoom. Couldn't find any option that would change this in any way. Can anyone tell me where the problem is?

Thanks
caiusmisus
 
Joined: 26 Nov 2020

Re: Automap display in the latest GZDoom.

Postby Hedda Smallforth » Thu Nov 26, 2020 3:52 pm

One possible reason based on the screenshot sizes. The ZDoom full screen image is 2560 x 1440 pixels, the cropped GZDoom 3103 x 2879.

GZDoom by default uses the display's native resolution. ZDoom's 2560 x 1440 pixels might have been the maximum. So your screen in GZDoom is now double more sharp than what it was in ZDoom. But the automap lines are still drawn to the same thickness as before. So they are seen as half more narrow.

I think there was a feature request to scale the automap lines more thick for big displays. But the devs (not just here) are busy and we really should be grateful for everything they do for free.

Try the console command: vid_scaletoheight 1440

It scales the screen down to the same 1440 height what it was in ZDoom. However it scales both the automap and the real game view. You'll get back the default unscaled view with: vid_scalefactor 1
Hedda Smallforth
 

Re: Automap display in the latest GZDoom.

Postby Graf Zahl » Fri Nov 27, 2020 2:13 am

This looks indeed like the lines are thinner on a large display and as a result cover less screenspace which makes them look darker.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Automap display in the latest GZDoom.

Postby caiusmisus » Fri Nov 27, 2020 6:30 am

Hedda Smallforth wrote:One possible reason based on the screenshot sizes. The ZDoom full screen image is 2560 x 1440 pixels, the cropped GZDoom 3103 x 2879.

GZDoom by default uses the display's native resolution. ZDoom's 2560 x 1440 pixels might have been the maximum. So your screen in GZDoom is now double more sharp than what it was in ZDoom. But the automap lines are still drawn to the same thickness as before. So they are seen as half more narrow.

I think there was a feature request to scale the automap lines more thick for big displays. But the devs (not just here) are busy and we really should be grateful for everything they do for free.

Try the console command: vid_scaletoheight 1440

It scales the screen down to the same 1440 height what it was in ZDoom. However it scales both the automap and the real game view. You'll get back the default unscaled view with: vid_scalefactor 1

I am still on the same screen with 2560x1440 resolution. I just probably found the problem. In the "video mode" menu, it kept resetting the custom scaling to double that of my resolution (5120x2880), hence the GZDoom strange screenshot dimensions that I had to crop (was wondering why it was so huge). Even if I set it to my resolution (which I did like 2 times), it would immediately swap back to it on next launch for some reason.

Anyway, after trying the command, it seems to be fixed and the solution persists between launches. Had to re-adjust my scaling settings, but the automap looks normal now and the lines don't shimmer. So thanks for the help :)
caiusmisus
 
Joined: 26 Nov 2020


Return to General

Who is online

Users browsing this forum: No registered users and 4 guests