Page 1 of 2

How to disable on-screen keyboard in save menu?

PostPosted: Fri Jul 19, 2019 5:22 pm
by bebipbop
https://i.imgur.com/bzzC9dR.png
How do I disable this keyboard? It's very annoying.

edit: to clarify, I know you can avoid it by pressing enter rather than clicking on it. I want to be able to click on it without the OSK coming up.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Sun Jul 21, 2019 7:31 am
by MFG38
To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Sun Jul 21, 2019 8:51 am
by _mental_
Set m_showinputgrid CVAR to -1.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Sun Jul 21, 2019 9:27 am
by Enjay
MFG38 wrote:To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.

That's certainly not required. My mouse is not disabled in the menus and I didn't even realise that keyboard existed. :shock:

Re: How to disable on-screen keyboard in save menu?

PostPosted: Mon Jul 22, 2019 8:00 am
by MFG38
Enjay wrote:
MFG38 wrote:To my knowledge, the only way to disable that is by disabling the mouse in menus (m_use_mouse 0), unless you use the "press Enter" workaround.

That's certainly not required. My mouse is not disabled in the menus and I didn't even realise that keyboard existed. :shock:


I stand corrected in that case.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Mon Jul 22, 2019 6:01 pm
by Xeotroid
It might be a good idea to update the wiki entry on it, then. If three values for it are accepted, it shouldn't even be noted as boolean.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Tue Jul 23, 2019 7:13 am
by bebipbop
Thanks for the help, guys :)

Re: How to disable on-screen keyboard in save menu?

PostPosted: Tue Jul 23, 2019 8:08 am
by Enjay
I just started GZDoom and typed m_noinputgrid at the console. It reported the value as 0. I changed it to 1 and got the grid. I changed to back to 0 and no longer got the grid. I also tried -1 and still no grid. I am wondering why is -1 recommended?

Re: How to disable on-screen keyboard in save menu?

PostPosted: Tue Jul 23, 2019 9:56 am
by _mental_
You need to use mouse or controller to get the grid when CVAR is zero. -1 disables it completely.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Tue Jul 23, 2019 10:23 am
by Enjay
Ah, right, I see it now. With it set at 0, if I actually use the mouse to click on the save name, the keyboard pops up. If I just do it using the enter key, the keyboard does not pop up (even though I could have used the mouse if I'd wanted, and thereby have gotten the keyboard). -1 does indeed stop it entirely.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Tue Jul 23, 2019 2:09 pm
by Graf Zahl
I think the documentation is older than the 'completely off' option. With the old menu code there was no mouse so there was no need to switch this off with the mouse enabled.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Thu Jul 25, 2019 2:27 pm
by Blue Shadow
Trying to update the wiki, is this correct for the various modes?
  • -1 - Disables the display of the grid.
  • 0 - Displays the grid only if a controller, such as a mouse or gamepad, is used.
  • 1 - Always displays the grid.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Thu Jul 25, 2019 2:33 pm
by _mental_
Yes, just one or greater in the last case.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Thu Jul 25, 2019 2:51 pm
by Blue Shadow
Thanks. Wiki updated.

Re: How to disable on-screen keyboard in save menu?

PostPosted: Thu Jul 25, 2019 3:38 pm
by Graf Zahl
For 0 is should read 'enable only', not 'disable only'.