Page 1 of 1

mapinfo syntax errors! :(

PostPosted: Tue Aug 05, 2003 9:22 am
by SyntherAugustus
Code: Select allExpand view
episode MAP01
name "Escape from Castle Wolfenstien"

episode MAP11
name "Operation Eisenfaust"

episode MAP21
name "Die Fuhrer Die!"

map map09
next map01
cluster 1
exitext "You Beaten Episode 1"

map map19
next map11
cluster 2
exitext "You Beaten Episode 2"

map map29
next map21
cluster 3
exitext "You Beaten Episode 3"


It keeps saying "Bad syntax line 11"

I've tried everything. what do I do? :oops:

PostPosted: Tue Aug 05, 2003 9:37 am
by Hirogen2
exitext!?
exittext probably.

PostPosted: Tue Aug 05, 2003 10:09 am
by SyntherAugustus
still getting line 11 error

PostPosted: Tue Aug 05, 2003 10:19 am
by Xaser
You spelled Exittext wrong. You accidentally put "exitext" instead of "exittext" (you put only one "t" instead of two). That's the problem.

PostPosted: Tue Aug 05, 2003 11:05 am
by HotWax
You're also using the exittext command improperly. There are two kinds of definitions in a MAPINFO lump. Maps, and clusters. All of the entries you list are map defeinitions. The exittext command is used for cluster definitions.

PostPosted: Tue Aug 05, 2003 11:26 am
by Kate
Let me change the code to something that'll work:
Code: Select allExpand view
clearepisodes
episode MAP01
name "Escape from Castle Wolfenstien"

episode MAP11
name "Operation Eisenfaust"

episode MAP21
name "Die Fuhrer Die!"

map map09
next map01
cluster 1

map map19
next map11
cluster 2

map map29
next map21
cluster 3

clusterdef 1
exittext "You Beaten Episode 1"

clusterdef 2
exittext "You Beaten Episode 2"

clusterdef 3
exittext "You Beaten Episode 3"

PostPosted: Tue Aug 05, 2003 3:18 pm
by SyntherAugustus
edit: now it says line 12 is bad. wth is going on here. could it be im using 47i?

PostPosted: Tue Aug 05, 2003 3:31 pm
by HotWax
blackfish wrote:edit: now it says line 12 is bad. wth is going on here. could it be im using 47i?


Are you using Destroyer's version? If so, it should work as all the syntax is correct. If you just corrected your spelling error, the issue is that you're trying to use "exittext" under a map definition. See my earlier post.

PostPosted: Tue Aug 05, 2003 4:26 pm
by SyntherAugustus
the syntax is fully correct. maybe check out the wad?

I am using 47i if that has to do with anything. Im sure it doesnt.

PostPosted: Tue Aug 05, 2003 5:47 pm
by Cyb
you need to give the maps a name

Code: Select allExpand view
map map## "put a name here like this"


that's what's causing the crash

PostPosted: Tue Aug 05, 2003 5:55 pm
by Kate
Cyb wrote:you need to give the maps a name

Code: Select allExpand view
map map## "put a name here like this"


that's what's causing the crash
Whoops! I forgot about that!

PostPosted: Tue Aug 05, 2003 7:58 pm
by SyntherAugustus
thanks cyb.