Page 1 of 2

Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 3:25 pm
by Ceeb
So, I don't feel like making an account for DRD Team, and furthermore I haven't even seen this mentioned in their bug section, but look at the weird shit happening in GZDoom r714. These were taken in my project Hell Worm, but they happen in any WADs I play, or even just IWADs by themselves.

Has anyone else experienced this? :? It happens with random sprites.

Image

Image

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 5:53 pm
by NeuralStunner
What setings do you use for Sprite Clipping, Resizing, Billboarding? Any specifics on your rendering settings, really.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 5:59 pm
by Enjay
NeuralStunner wrote:What setings do you use for Sprite Clipping, Resizing, Billboarding? Any specifics on your rendering settings, really.

My queries too. I've certainly not seen anything like that myself.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 6:24 pm
by Ceeb
Clipping is Smart, don't know what you mean by resizing, and billboarding is Y axis only.

This happens at random. That baron was normal until it threw a fireball, when it compressed like that. After that frame it returned to normal.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 7:19 pm
by Zero X. Diamond
This same thing is happening to me in GZDoom. Just posted a thread about it on DRD Team's GZDoom Bug forum, though I don't know if it's got to be approved first or what the hell ever. It appears to be directly related to the scaling method; when it's changed to 3x, the frames that squish up return to normal, but everything else gets horribly stretched out.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 7:20 pm
by Vader
Ceeb wrote:This happens at random. That baron was normal until it threw a fireball, when it compressed like that. After that frame it returned to normal.


Almost sounds like a feature;
in-game sprite resizing anyone :P

Anyway, I haven't seen anything like that so far.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 7:42 pm
by Enjay
Zero X. Diamond wrote:though I don't know if it's got to be approved first or what the hell ever.

A user's first post over at DRD has to be approved by a mod as an anti-spam device. I just approved your thread so future posts by you won't need approval.

I noticed that you are using an ATI Radeon 9200. I wonder what card Ceeb is using. I'm using a GeForce 285 GTX and have not seen this so I'm wondering if it's an ATI thing.

As for getting a quick fix, unfortunately Graf is away on business and won't be back for a couple of weeks. So, nothing will happen until then.

Re: Weird glitchy crap...

PostPosted: Thu Jan 07, 2010 8:56 pm
by Ceeb
Enjay wrote:I wonder what card Ceeb is using.


ATI Radeon X1650, although I used to have a 9200 SE. :P

Re: Weird glitchy crap...

PostPosted: Fri Jan 08, 2010 4:58 am
by Graf Zahl
Damn. I recently added a feature to crop the edges of sprites that contain a lot of empty space. It looks that this does not work on old ATI cards which do not support textures with dimensions that are not a power of two. But I'm sorry, you'll have to live with it for the next 2 weeks. I'm not at home right now and neither have access to the DRDTeam forum nor the SVN so I can't fix it.

Re: Weird glitchy crap...

PostPosted: Fri Jan 08, 2010 5:09 am
by Cutmanmike
Vader wrote:in-game sprite resizing anyone :P


WFDS or find some crazy bug to help you out?! :wink:

Re: Weird glitchy crap...

PostPosted: Fri Jan 08, 2010 7:59 am
by Xaser
That is more or less ZDoom's unspoken mantra. :P

Re: Weird glitchy crap...

PostPosted: Fri Jan 08, 2010 10:44 am
by ReX
I'm having the same problems too, but they are momentary. In other words, the sprites generally show up with no issues, but for brief instants they get flattened. Here are examples:

Flattened Sprite.jpg
Flattened Sprite
Flattened Sprite.jpg (19.69 KiB) Viewed 1921 times


Normal Sprite.jpg
Normal Sprite (screenshot taken an instant after the previous one)
Normal Sprite.jpg (20.04 KiB) Viewed 1922 times

Re: Weird glitchy crap...

PostPosted: Sat Jan 09, 2010 7:55 pm
by The Ultimate DooMer
I just found this too...the reiver from Hexen squashes up from behind and some of my custom mobs don't render properly at all. Needless to say, I'm somewhat relieved to know the cause (having just had a major scare before this with it not loading at all until finding out that XWE chewed up my graphics wad) and 1.4.0 will do for the meantime while Graf's away.

Re: Weird glitchy crap...

PostPosted: Sat Jan 09, 2010 9:44 pm
by Godzilla
are you using Xscale or scale
Also nice screenies, doom64/shadow warrior :D both your projects look promising.

Re: Weird glitchy crap...

PostPosted: Sun Jan 10, 2010 2:01 pm
by Gez
Graf Zahl wrote:Damn. I recently added a feature to crop the edges of sprites that contain a lot of empty space. It looks that this does not work on old ATI cards which do not support textures with dimensions that are not a power of two. But I'm sorry, you'll have to live with it for the next 2 weeks. I'm not at home right now and neither have access to the DRDTeam forum nor the SVN so I can't fix it.

I have an experimental build ready which should solve the issue then.