Page 27 of 30

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sun Jun 12, 2016 1:48 am
by Wivicer
I'm loading lights.pk3 and brightmaps.pk3. Just those 2. the gameplay mod is ral_light_v4.1.pk3, but I tried it with vanilla doom and the same thing happens. Just to be clear, this is with gzdoom osx version 0.5.7, the prerelease.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sun Jun 12, 2016 3:23 am
by Gez
I don't remember textures being present in the official brightmaps.pk3.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sun Jun 12, 2016 4:21 am
by _mental_
I didn't see any problems using 0.5.7 with the following command line and without any autoloaded stuff:
Code: Select allExpand view
-iwad doom2 -file lights.pk3 brightmaps.pk3 ral_light_v4.1.pk3

What are those brightmapped textures you mentioned? The brightmaps.pk3 supplied with GZDoom contains sprites only.
Maybe your hardware spec will shed some light on this issue.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sun Jun 12, 2016 3:14 pm
by Wivicer
You're right. I forgot I was loading sbrightmaps.pk3 as well.
Ha, shed some light.
I'm at work right now, but I'll post my specs when I get home.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Wed Jun 15, 2016 3:47 pm
by Wivicer
MacBook Pro (15-inch, Early 2011)
Processor: 2.2 GHz Intel Core i7
Memory: 8 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 512 MB

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Fri Jun 17, 2016 1:12 am
by _mental_
Wivicer wrote:You're right. I forgot I was loading sbrightmaps.pk3 as well.

Everything I can do at the moment is to confirm that loading sbrightmaps.pk3 is causing this issue.
However it's not specific to OS X, the problem is in compatibility OpenGL 2.x renderer. Probably some feature is not implemented yet. Graf knows much more on this topic.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Fri Jun 17, 2016 11:36 pm
by Wivicer
Ok. Thanks anyway.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sun Jun 19, 2016 4:17 am
by _mental_
Wivicer wrote:Ok. Thanks anyway.

This bug has been fixed. The next binary release will work properly when both dynamic lights and brightmaps for textures are loaded.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Wed Jun 29, 2016 3:19 pm
by printz
When I try to load the Mac ZDoom from devbuilds.drdteam.org, I'm told it cannot find ZDoom.pk3!

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Wed Jun 29, 2016 11:17 pm
by _mental_
Indeed .pk3 is missing from the package. Blzut3 should take a look at this.
Probably the file from Windows build can used if difference in line endings doesn't break something. It must be placed near executable inside application bundle.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Fri Jul 01, 2016 2:28 pm
by printz
I tried zdoom.pk3 from Windows, same upload day. I got this error:

Execution could not continue.
Script error, "zdoom.pk3:actors/actor.txt" line 135:
Invalid return type void

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Sat Jul 02, 2016 12:38 am
by _mental_
The situation with macOS devbuilds is worse than I expected.
Not only .pk3 is missing, x64 binary is stopped updating at 2.9pre-506-g1648a71.
In other words PowerPC part of universal executable matches disk image version but x64 is not.
This explains the error you got.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Tue Aug 09, 2016 12:16 am
by printz
Now it works, but every time I open the app, I get a standard warning that "I'm opening it for the first time; am I sure I want to open it?". Also, it starts with the window behind other windows.

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Tue Aug 09, 2016 12:47 am
by _mental_
Have no idea, what's your hardware and OS version?

Re: The official "ZDoom on Mac OS X" thread.

PostPosted: Tue Aug 09, 2016 3:08 am
by printz
I'm using El Capitan on a MacBookPro mid-2012