Page 1 of 1

[HELP] Compiling errors...

PostPosted: Thu Jul 24, 2003 8:03 pm
by kevingpo
Ok. When compiling ZDoom 2.x.x I get this error (and only this):

Assembler messages:
FATAL: can't create devcobj/am_map.o: No such file or directorymake.exe: *** [devcobj/am_map.o] Error 1Execution terminated

Also, do I need DirectX SDK?

Re: [HELP] Compiling errors...

PostPosted: Fri Jul 25, 2003 12:47 am
by HotWax
kevingpo wrote:Also, do I need DirectX SDK?


AFAIK, ZDoom uses DirectDraw, so yeah.

PostPosted: Fri Jul 25, 2003 5:28 am
by rpeter
Do you have nasmw on your path?

You also need fmod sdk and directx sdk. This is where the most newbie abandons mingw: you cannot use a MSVC sdk directly with mingw, you need to hunt down mingw specific ones. No problem with fmod, try devc's package manager to get directx for mingw.

PostPosted: Fri Jul 25, 2003 5:26 pm
by kevingpo
What is FMod? And where can I get it?

Am sure DirectX SDK can be used for Dev-C++ (mingw) - if ZDoom 2.x.x now includes a Dev-C++ file.

PostPosted: Fri Jul 25, 2003 5:30 pm
by Mighty Duck X-treme
kevingpo wrote:What is FMod? And where can I get it?


http://www.fmod.org

PostPosted: Fri Jul 25, 2003 9:06 pm
by Xaser
Hmm... so FMod supports .IT Files. Does that mean that I can use .ITs in PWads? In the past, when I tried to use an .IT, Zdoom gives an error message (song has abrupt ending, or somthing like that), and won't play the song. Then again, that was 1.22, which is what I used right before version 2.47 (wow, major upgrade there!).

PostPosted: Sun Jul 27, 2003 11:44 pm
by rpeter
>>Am sure DirectX SDK can be used for Dev-C++ (mingw) - if ZDoom >>2.x.x now includes a Dev-C++ file.

I didn't mean you cannot do directx things with devc (which is just an ide on top of mingw), but I don't think you get the directx sdk ready to use with mingw or the devc package. Actually, only about three headers files are needed for zdoom which Randy could include in the sources... but I'm not a lawyer.

For reference I have successfully built Quake1, Quake2, Duke3d (Dx version) and a couple of standard win32 gui app with mingw. But just double clicking on the project file won't work.

PostPosted: Mon Jul 28, 2003 2:17 am
by HotWax
Xaser wrote:...version 2.47...


Just to clarify, the current (publicly released) version is 2.0.47, not 2.47. When Randy decides to take ZDoom back out of "beta" status (and there is currently a running bet as to whether this will happen before hell freezes over) it will be version 2.1.

PostPosted: Mon Jul 28, 2003 1:24 pm
by Xaser
HotWax wrote:
Xaser wrote:...version 2.47...


Just to clarify, the current (publicly released) version is 2.0.47, not 2.47. When Randy decides to take ZDoom back out of "beta" status (and there is currently a running bet as to whether this will happen before hell freezes over) it will be version 2.1.


Doh!