zdoom's midi system (percussion too loud?)

Discuss anything ZDoom-related that doesn't fall into one of the other categories.

zdoom's midi system (percussion too loud?)

Postby Virgil » Sun Nov 02, 2003 7:11 pm

I'm using Creative S/W Synth as my device and tried Creative SB Live! as midi device. Both seem ok, but their percussion is WAY too loud. I can't hear the piano/organ/strings/etc. Is there any way for me to turn down the volume on just the percussion? I love to listen to numerous doom midi tunes while playing zdoom and this is really ruining the experience for me.

P.S. My old win95 computer has an old crappy midi card and it makes midis sound much better than my win98 O/S with my new sound card. Can you say "sound card manufacturers don't give a shit about midi"?
User avatar
Virgil
 
Joined: 28 Sep 2003

Postby HotWax » Sun Nov 02, 2003 8:36 pm

SB Live! midi sounds just fine to me.
User avatar
HotWax
Do what you must, and pay the price later.
 
Joined: 18 Jul 2003
Location: Idaho Falls, ID

Postby Virgil » Sun Nov 02, 2003 9:37 pm

Nm, problem fixed. I installed timidity for zdoom and then dl-ed Eaw patches for GUS. Now it sounds a lot more like my old computer's midi.
User avatar
Virgil
 
Joined: 28 Sep 2003

Postby Virgil » Sun Nov 02, 2003 10:58 pm

There's however one thing that I don't like when using timidity in zdoom. Most doom songs are designed to be looped without the pause at the end. Is there any way to get rid of the pause that timidity makes before restarting the song?
User avatar
Virgil
 
Joined: 28 Sep 2003

Postby Kappes Buur » Mon Nov 03, 2003 8:23 am

.
Didn't Randy scrub Timidity quite some time ago, and now uses FMOD instead?
.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada

Postby arioch » Mon Nov 03, 2003 10:27 am

Virgil wrote:There's however one thing that I don't like when using timidity in zdoom. Most doom songs are designed to be looped without the pause at the end. Is there any way to get rid of the pause that timidity makes before restarting the song?

Sure is. Disable Timidity.
Kappes Buur wrote:Didn't Randy scrub Timidity quite some time ago, and now uses FMOD instead?

No, he added Timidity support way after fmod to support MIDI on Linux systems.
User avatar
arioch
hcoira
 
Joined: 15 Jul 2003

Postby Chilvence » Mon Nov 03, 2003 10:57 am

It took me 3 months after getting this audigy 2 to find out that the h/w midi synth used exactly the same patches as the ones I had downloaded for timidity...

Anyway, if the midi is really bad, cant you just go around looking for soundfonts to use? Im sure theres some control panel in the SB live that allows you to load a custom s.f.
User avatar
Chilvence
I had been waiting for Doomscript....
 
Joined: 11 Aug 2003

Postby Virgil » Mon Nov 03, 2003 5:26 pm

Aren't sound fonts used in custom midi files to make them sound more wave-like? Or can they actually modify how midi sounds on your system in general? I've loaded lots of sound fonts I dl-ed on my SB Live but it didn't make the doom music (or even midi music) sound any different.
User avatar
Virgil
 
Joined: 28 Sep 2003

Postby Virgil » Mon Nov 03, 2003 5:28 pm

I'm not disabling timidity if it sounds better than whatever half-assed midi emulation my SB Live has. It isn't the best option, but it improves the atmosphere of gameplay when you can actually hear the strings/piano/low menacing bass instead of loud, obnoxious percussion and high-treble.
User avatar
Virgil
 
Joined: 28 Sep 2003

Postby Chris » Mon Nov 03, 2003 5:43 pm

Try checking for trebble and bass controls in the volume control dialog(you'll probably have to enable the Advanced buttons if you haven't already) under the MIDI sliders.
User avatar
Chris
 
Joined: 17 Jul 2003


Return to General

Who is online

Users browsing this forum: No registered users and 2 guests