(GLES) Texture flickering , black areas instead of textures

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

(GLES) Texture flickering , black areas instead of textures

Postby ClessxAlghazanth » Sun Sep 19, 2021 5:56 am

Using the latest github build from here

https://devbuilds.drdteam.org/gzdoom/gz ... cc5a272.7z

Using open gl-es renderer , I got wall textures disappearing and appearing here and there , flickering of textures , and black areas here and there

Tried with vanilla and a few mods , applies to all

I didn't have this issue with GZDoom-gles 4.6.1 which I've been using so far

.ini file and system details for reference

best regards
You do not have the required permissions to view the files attached to this post.
User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby ClessxAlghazanth » Sun Sep 19, 2021 6:02 am

Sorry for double-posting due to attachment limit , here's my .ini file
You do not have the required permissions to view the files attached to this post.
User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby Graf Zahl » Sun Sep 19, 2021 6:57 am

I made some changes here. Can you please retest? I was only partially experiencing your issues so I need confirmation.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: (GLES) Texture flickering , black areas instead of textu

Postby ClessxAlghazanth » Sun Sep 19, 2021 7:08 am

Graf Zahl wrote:I made some changes here. Can you please retest? I was only partially experiencing your issues so I need confirmation.


Thanks a lot for the kind response :D

Should I download from the same link at drdteam/devbuilds (pre-195 one) ?
User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby Graf Zahl » Sun Sep 19, 2021 7:39 am

Yes, as soon as the next one becomes available.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: (GLES) Texture flickering , black areas instead of textu

Postby ClessxAlghazanth » Mon Sep 20, 2021 6:12 am

Graf Zahl wrote:Yes, as soon as the next one becomes available.


Thanks , I tried the latest (today's) github devbuild (pre-197 one) , and while there are less errors , they are not completely gone. I still get flickering & black textures at walls (almost seems random). The overall performance isn't effected (no frame drops or anything)

One thing I noticed that Doom Incarnate's main menu screen bugs out like crazy (which features a lot of smoke & flame with corpses around)
(It could be a good way to check this problem)

I wonder if this is an issue in which some decals not being processed properly ? (Never encountered such issue in GZDoom-gles 4.6.0b & 4.6.1)

Best regards

EDIT : Uploaded 2 short videos to yt demonstrating the issue (sorry for the low quality)



User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby emile_b » Mon Sep 20, 2021 2:48 pm

I finally managed to reproduce this on my machine - it only happens when in full screen on the laptop screen for me. Windowed mode or on an external monitor did not have the problem.

The problem was I didn't have buffer synchronisation when using GLES renderer, this wasn't an issue when HW_MAX_PIPELINE_BUFFERS = 4, but now it's reduced to 2 the engine can 'catch up' with a buffer in use and corrupt the data.

This *may* suggest that having HW_MAX_PIPELINE_BUFFERS higher than 2 might add more performance but I'm not sure.

https://github.com/coelckers/gzdoom/pul ... 66089e0957
emile_b
 
Joined: 22 Sep 2019
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: (GLES) Texture flickering , black areas instead of textu

Postby Graf Zahl » Mon Sep 20, 2021 3:29 pm

Ok, in this case it may make sense setting it to 4 again. I wanted to avoid that because it inflates several internal data structures.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: (GLES) Texture flickering , black areas instead of textu

Postby ClessxAlghazanth » Mon Sep 20, 2021 5:21 pm

Thanks a lot for checking the issue :)

I did further testing (switching between fs and windowed mode , running on laptop screen - I normally use external monitor) and the issue is always there

I'll test and report again as soon as the next devbuild becomes available
User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby ClessxAlghazanth » Tue Sep 21, 2021 5:26 am

I just gave pre-204 a shot and voila :P all the texture glitches are gone ! It works without any noticeable issues so far , and it's great to have most (if not all) the recent updates/fixes while running on fast gles renderer :wub:

Not only that , but spotlights behave as they should (I played a round of EVP with it) , can finally use flashlight mods as intended :D

Thanks to Graf , emile and everyone involved 8-)
You do not have the required permissions to view the files attached to this post.
User avatar
ClessxAlghazanth
 
Joined: 17 Feb 2019

Re: (GLES) Texture flickering , black areas instead of textu

Postby Graf Zahl » Tue Sep 21, 2021 5:51 am

Good to hear. :)
This was one of the last issues standing in the way of 4.7.0. If all goes well it should be out later today.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: (GLES) Texture flickering , black areas instead of textu

Postby Enjay » Tue Sep 21, 2021 6:05 am

Can anything be done about this one before 4.7.0 or is it too much for the next release?

viewtopic.php?f=2&t=70492
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: (GLES) Texture flickering , black areas instead of textu

Postby Graf Zahl » Tue Sep 21, 2021 7:06 am

I have no idea how to deal with this without breaking the core guarantee of the GC, i.e. that you can be assured that all pointers to destroyed objects remain valid until execution control reaches the internal main loops again.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: (GLES) Texture flickering , black areas instead of textu

Postby emile_b » Tue Sep 21, 2021 8:36 am

Graf Zahl wrote:Good to hear. :)
This was one of the last issues standing in the way of 4.7.0. If all goes well it should be out later today.


Great! Will do a small PR later today if there is still time, it is to check gles.usemappedbuffer = true before using the glSync stuff here:

https://github.com/coelckers/gzdoom/blo ... s.cpp#L235

Also to check the glClientWaitSync function pointers are not null, in case using a very old OpenGL version which does not have them to avoid a crash.
emile_b
 
Joined: 22 Sep 2019
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)


Return to OpenGLES Renderer Bugs

Who is online

Users browsing this forum: No registered users and 0 guests