Page 1 of 1

Game-data paths on Mac?

PostPosted: Tue Jun 22, 2021 6:47 pm
by doomseal
I'm trying to get Raze 1.1.2 up and running, but I can't seem to find where to put the .grp and .ssi files on a Mac.

The Wiki says "Game files should be placed in your Library folder" but the Library folder is a big place with many subfolders. The "Getting build games to work" thread has relative paths, but no base other than "your raze folder."

I've tried many different folders but it always says "unable to find any game data."

Can anyone point me to the right documentation page or the correct folder path?

Re: Game-data paths on Mac?

PostPosted: Tue Jun 22, 2021 11:50 pm
by _mental_

Re: Game-data paths on Mac?

PostPosted: Wed Jun 23, 2021 6:47 am
by doomseal
Thanks for that information. I've used zdoom/gzdoom for years now and didn't even think of looking in the INI file. Honestly, I didn't think it would exist yet since Raze had never finished starting up.

I found the Raze.ini file, and put duke3d.grp and duke.rts into several of the folders listed there, and it still won't find them. These are retail files copied off the CDs. They work great on the Windows box, but the two Macs just won't find them. I have both atomic edition 1.5 and 1.3d, neither works.

I tried both the all-caps filenames favored by the CD filesystem and all-lower. is there a specific capitalization it needs? What am I still missing?

(Maybe this needs moved to the Bugs forum? I thought the issue was just me not knowing the correct paths.)

The main system I'm using is an "iMac19,2 running macOS Big Sur 10.16.0 (20F71) 64-bit Intel"

Re: Game-data paths on Mac?

PostPosted: Wed Jun 23, 2021 8:31 am
by _mental_
There is no bug here, it works for me just fine. It doesn't matter how many Macs cannot find the data if their users copied files to wrong locations.

Open Terminal, do ls -lR ~/Documents/Raze command there, and post its output.
Spoiler: Here is what I've got

Re: Game-data paths on Mac?

PostPosted: Wed Jun 23, 2021 2:17 pm
by doomseal
Code: Select allExpand view
[~] $ ls -lR ~/Documents/Raze/                                                 
total 87024                                                                     
-rwxr-xr-x  1 doomseal  staff    188954 Dec 11  1996 DUKE.RTS*                 
-rwxr-xr-x  1 doomseal  staff  44356548 Dec 11  1996 DUKE3D.GRP*               
-rw-r--r--  1 doomseal  staff        93 Jun 22 21:15 raze.log                   

I've tried it with the names both all-caps and all-lowercase and it doesn't work either way.

On my Catalina machine, I got it to run if I launched raze from the terminal, when the working directory (.) contained the GRP files. Launching it from Finder/Spotlight doesn't find the data files on either machine.

EDIT: Seems that if I run it from my home directory, it manages to find the GRP files. Weird that the working directory has to be ~ to work.

Re: Game-data paths on Mac?

PostPosted: Thu Jun 24, 2021 4:29 pm
by doomseal
Sorry for the double post, but I got it to work.

In the INI file, most of the directory paths end with /*. This means look in any subdirectories of this directory, not in the directory itself. So, as the other thread suggests, put the files in a 'data' subdirectory of any of the directories listed in the ini file.

Thanks for the assistance, and sorry if I was a bit dense.