[RR] Skinny old coot not playing sound files.

Moderator: Raze Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
Fat_Angus
Posts: 64
Joined: Mon Jun 12, 2017 5:52 pm

[RR] Skinny old coot not playing sound files.

Post by Fat_Angus »

I fired up the latest version of raze and I noticed that the skinny old coot in redneck rampage is not playing some of its sound files, such as 'i'm gonna getcha, boy" upon seeing the player and randomly laughing. It does say 'get off my land' though. This is also the case with Redneck Rampage Rides Again.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47994
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [RR] Skinny old coot not playing sound files.

Post by Graf Zahl »

Plays fine for me.
Fat_Angus
Posts: 64
Joined: Mon Jun 12, 2017 5:52 pm

Re: [RR] Skinny old coot not playing sound files.

Post by Fat_Angus »

It's hit and miss for me. I've deleted and reinstalled everything from scratch. Still the same problem. For instance, the first time you start a new game and load the map taylor town, the coot to the left will automatically start saying 'i'm gonna getcha boy'. But this doesn't happen. And the frequency of enemy sound playback is noticeably different from that using the original game executable as well (and the previous version of Raze). They don't play as often as they should.
Fat_Angus
Posts: 64
Joined: Mon Jun 12, 2017 5:52 pm

Re: [RR] Skinny old coot not playing sound files.

Post by Fat_Angus »

Rednukem does not have this issue, nor does BuildGDX. Both of them are faithful to the original.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47994
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [RR] Skinny old coot not playing sound files.

Post by Graf Zahl »

Can you try a few older releases to find out where this started?
Fat_Angus
Posts: 64
Joined: Mon Jun 12, 2017 5:52 pm

Re: [RR] Skinny old coot not playing sound files.

Post by Fat_Angus »

I've traced it back to 0.51. That version has the enemies playing the correct sounds, i.e. the skinny coot says 'I'm gonna get ya' upon seeing the player when in later versions he does not. Other enemies may also be affected by this issue.
User avatar
mjr4077au
Posts: 719
Joined: Sun Jun 16, 2019 9:17 pm
Discord: mjr4077au#1027
Github ID: mjr4077au
Graphics Processor: nVidia with Vulkan support
Location: Gosford NSW, Australia

Re: [RR] Skinny old coot not playing sound files.

Post by mjr4077au »

@Fat_Angus, can you please try a newer devbuild? https://devbuilds.drdteam.org/raze/

After some internal discussions we reverted EDuke32's implementation of krand (Build's RNG) to the original algorithm which is what is used by Redneck Rampage and GDX ports.
User avatar
mjr4077au
Posts: 719
Joined: Sun Jun 16, 2019 9:17 pm
Discord: mjr4077au#1027
Github ID: mjr4077au
Graphics Processor: nVidia with Vulkan support
Location: Gosford NSW, Australia

Re: [RR] Skinny old coot not playing sound files.

Post by mjr4077au »

Closing due to non-contact. With the RNG setup, its about as good as it gets. If the RNG is different because something called krand() and changed its valuation, not much that can be done.
Fat_Angus
Posts: 64
Joined: Mon Jun 12, 2017 5:52 pm

Re: [RR] Skinny old coot not playing sound files.

Post by Fat_Angus »

The issue is that the coot sounds don't play upon first seeing the player like it does in the original engine and other ports. Red Nukem does this, Raze does not.
User avatar
wildweasel
Moderator Team Lead
Posts: 21384
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: [RR] Skinny old coot not playing sound files.

Post by wildweasel »

Fat_Angus wrote:The issue is that the coot sounds don't play upon first seeing the player like it does in the original engine and other ports. Red Nukem does this, Raze does not.
Have you tried a dev build, though?
User avatar
mjr4077au
Posts: 719
Joined: Sun Jun 16, 2019 9:17 pm
Discord: mjr4077au#1027
Github ID: mjr4077au
Graphics Processor: nVidia with Vulkan support
Location: Gosford NSW, Australia

Re: [RR] Skinny old coot not playing sound files.

Post by mjr4077au »

If it's not right in 1.4 then it won't be in a devbuild unfortunately. I'll add it to my list of things to look at

Return to “Closed Bugs”