[Fixed] [Duke3D: NW] [newrenderer] Deja Vu textures disappearing bug

Moderator: Raze Developers

[Duke3D: NW] [newrenderer] Deja Vu textures disappearing bug

Postby Cacodemon345 » Wed May 12, 2021 12:30 pm

In Duke3D Nuclear Winter, there is a bug in the new renderer where part of the box in the starting area will disappear when looking at it from a certain angle and position.

Image

Here is the attached save file causing this bug.
You do not have the required permissions to view the files attached to this post.
Cacodemon345
 
Joined: 22 Dec 2017
Discord: Cacodemon345#9151
Github ID: Cacodemon345
Operating System: Other Linux 64-bit
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [Duke3D: NW] [newrenderer] Deja Vu textures disappearing

Postby Cacodemon345 » Sun May 16, 2021 11:52 am

This is indeed fixed in the latest commit but what was the reason for this bug?
Cacodemon345
 
Joined: 22 Dec 2017
Discord: Cacodemon345#9151
Github ID: Cacodemon345
Operating System: Other Linux 64-bit
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [Duke3D: NW] [newrenderer] Deja Vu textures disappearing

Postby Graf Zahl » Sun May 16, 2021 12:23 pm

- newrenderer: clip wall angles before doing any math with them.

In some cases these unclipped ranges ended up in other data structures, causing problems with bunch ordering.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests