[Can't reproduce] Crash with SW while using SW Voxel Pack

Moderator: Raze Developers

Crash with SW while using SW Voxel Pack

Postby Gen5lock131 » Mon May 10, 2021 11:02 pm

Posted on general because this seems to be a mod incompatibility more than a bug on Raze's side, I think.

While trying out the new 1.1 version of Raze with shadow warrior I could not help but notice that for whatever reason some voxels in the SW voxel pack ( https://forums.duke4.net/topic/7030-shadow-warrior-the-missing-voxels-shadow-warrior-voxel-pack/page__hl__%2Bshadow+%2Bwarrior+%2Bvoxel I am using the version of the voxel pack on page 6.) crash Raze. Specifically:

blackstu.kvx
lampesp.kvx
court.kvx
drkit.kvx

Is there a reason why this could be happening? If I comment out the voxels in the def file everything as it should.

Attached a crash report I saved while troubleshooting in hopes it can be helpful.

Thanks in advance dudes.
You do not have the required permissions to view the files attached to this post.
User avatar
Gen5lock131
 
Joined: 09 Sep 2020
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Crash with SW while using SW Voxel Pack

Postby Graf Zahl » Mon May 10, 2021 11:53 pm

What would help more would be some info about places where in the maps it crashes. I'd have to see the crash for myself.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Crash with SW while using SW Voxel Pack

Postby Gen5lock131 » Tue May 11, 2021 12:33 am

Sorry, I may not have explained that well myself on the first post. The game actually never loads. It actually crashes while the game is starting up.

Exmaple with blackstu.kvx: https://imgur.com/a/9ixuNED

EDIT: TLDR I FOUND THE PROBLEM, THE VOXELS WERE MISSING. After messing around with the files I think I found the problem. It seems the voxel files were not added to the archive and therefore when Raze was loading them it could not find them, so it refused to start. This problem went unnoticed because when eduke32 does not find a voxel file it just report it as missing then starts the game without it.

I downloaded the missing voxels from the thread and problem solved.

For anyone interested the only voxel that is missing from anywhere is blackstu.kvx, so you will need to comment that one out definitely.
User avatar
Gen5lock131
 
Joined: 09 Sep 2020
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Crash with SW while using SW Voxel Pack

Postby markanini » Tue May 11, 2021 2:04 am

Still sounds like a bug, Raze is usually lenient with def errors, just like the other ports.
markanini
 
Joined: 18 Jan 2020

Re: Crash with SW while using SW Voxel Pack

Postby Graf Zahl » Tue May 11, 2021 2:12 am

Out of curiosity, where did you get the file from? The one I downloaded has no .def file, only swvoxfil.txt.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Crash with SW while using SW Voxel Pack

Postby Gen5lock131 » Tue May 11, 2021 3:08 am

From page 6 post 152. The author of the upload updated it to correct the problem and organize it. Quote from latest post on Duke4:

So I decided to organize the SWVP. In short order what I did was:

1.- Added a folder named "voxels" and moved all voxels to said folder
2.-Added 5 new subfolders: animated, monsters, switches, twindragon (Twin Dragon) & wantondes (Wanton Destruction) and moved the appropiate voxels to said subfolders
3.-Reorganized the swvoxel.def file. Added sw.def and sw-raze.def files.

Tested compatible with both VoidSW and Raze.

I don't really understand how to make the TD voxel only appear while playing TD on Raze so I commented it out.

Cheers.
User avatar
Gen5lock131
 
Joined: 09 Sep 2020
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Crash with SW while using SW Voxel Pack

Postby Rachael » Tue May 11, 2021 3:15 am

I moved this to the appropriate subforum.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Crash with SW while using SW Voxel Pack

Postby Graf Zahl » Tue May 11, 2021 3:43 am

Can't you just please post a link to the actual download?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Crash with SW while using SW Voxel Pack

Postby Gen5lock131 » Tue May 11, 2021 4:10 am

-Rachael: Thanks.

-Graf: Asked the guy and he uploaded it to GDrive: https://drive.google.com/file/d/1qjTIY_cPNqE02C33KMvbjTRv9PYL7pLV/view?usp=sharing This is the newest upload with everything organized and working with Raze.

I tried it myself and I can confirm it does work on raze. Pretty cool to see moving lamps and stuff.
User avatar
Gen5lock131
 
Joined: 09 Sep 2020
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Crash with SW while using SW Voxel Pack

Postby markanini » Tue May 11, 2021 4:19 am

Gen5lock131 wrote:-Rachael: Thanks.

-Graf: Asked the guy and he uploaded it to GDrive: https://drive.google.com/file/d/1qjTIY_cPNqE02C33KMvbjTRv9PYL7pLV/view?usp=sharing This is the newest upload with everything organized and working with Raze.

I tried it myself and I can confirm it does work on raze. Pretty cool to see moving lamps and stuff.

Correct me if I'm wrong but I think Graf asked for the version that caused the issue.
markanini
 
Joined: 18 Jan 2020

Re: Crash with SW while using SW Voxel Pack

Postby Graf Zahl » Tue May 11, 2021 4:29 am

Of course. I have made some changes to the code and could not reproduce anything with a .def file I quickly slapped together myself, so I need the precise file that caused the crash.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Crash with SW while using SW Voxel Pack

Postby Gen5lock131 » Tue May 11, 2021 4:30 am

Ho, here it is the initial file I downloaded: https://drive.google.com/file/d/16hA--5 ... CtKkr/view (link from the uploder's post)
User avatar
Gen5lock131
 
Joined: 09 Sep 2020
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Crash with SW while using SW Voxel Pack

Postby Graf Zahl » Tue Jun 01, 2021 1:24 pm

Checked this again, no crash for me. Since I cannot reprduce the problem at all this will get closed now.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest