[Fixed] [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Moderator: Raze Developers

[1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby NightFright » Fri Jun 11, 2021 9:11 am

Raze always crashes to desktop with a "Very Fatal Error" at the end of the cutscenes in "The Last Warrior" addon for Shadow Warrior. This occurs at the end of level 4 (first cutscene) and also at the end of level 14 (second cutscene). Aborting the cutscene would continue without crash.

Tested with snapshot: raze-x64-1.1.0pre-203-g4b35a30de

How to test:
- Download "The Last Warrior" (custom PK3 version, 12.2 MB)
- Load savegame "Quicksave" (zip, 0.3 MB) from my gameplay session. It puts you right after the boss in level 14 dies, so all you have to do is wait a few seconds. The cutscene will start automatically.
- Let the cutscene play until the end.
User avatar
NightFright
Spotlight Team
 
Joined: 02 May 2008
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby Graf Zahl » Fri Jun 11, 2021 1:11 pm

It crashes while rendering the last frame of the cutscene. That file appears to be a bit broken. It reports having 128 frames, but trying to decode frame 127 will make it crash.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby NightFright » Fri Jun 11, 2021 2:03 pm

Did this work with other ports? Maybe some error tolerance needs to be added for this one.
User avatar
NightFright
Spotlight Team
 
Joined: 02 May 2008
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby Graf Zahl » Fri Jun 11, 2021 2:06 pm

No idea. I haven't played this mod with any port yet. But the anmlib code is virtually unchanged from EDuke32.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby NightFright » Fri Jun 11, 2021 2:53 pm

Maybe the error can just be made non-fatal. I gotta admit, it's the first time I'm playing this.
User avatar
NightFright
Spotlight Team
 
Joined: 02 May 2008
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby Graf Zahl » Fri Jun 11, 2021 2:57 pm

The crash happens when it reads past the end of a memory block. So I got to find out how to validate it.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby mjr4077au » Sat Jul 24, 2021 12:10 am

This is possibly addressed by this commit. @NightFright, any chance you could please confirm?
User avatar
mjr4077au
 
Joined: 16 Jun 2019
Location: Gosford NSW, Australia
Discord: mjr4077au#1027
Github ID: mjr4077au
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: [1.1.2+/SW] Crash after cutscene in "The Last Warrior"

Postby Graf Zahl » Fri Aug 13, 2021 1:49 pm

The cutscene did not crash when I played the mod.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests