[0.4.0] "Main display" ignored in multi-monitor setup

Moderator: Raze Developers

[0.4.0] "Main display" ignored in multi-monitor setup

Postby Sangman » Tue Feb 04, 2020 4:00 pm

- Using Windows 10
- 2 monitors with "extend" setting
- Monitor #2 is set to be main display

When starting Raze, it will start on Monitor #1 each time until I disable it.

I was testing Duke3D when encountering this.
Sangman
 
Joined: 04 Feb 2020

Re: [0.4.0] "Main display" ignored in multi-monitor setup

Postby Graf Zahl » Tue Feb 04, 2020 4:09 pm

This is a known issue with Windows's OpenGL implementation. You can set the preferred monitor by altering the vid_adapter CVAR in the console.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [0.4.0] "Main display" ignored in multi-monitor setup

Postby Sangman » Tue Feb 04, 2020 4:13 pm

While I believe that, this doesn't happen in regular Eduke32, IMO that's not a reasonable response.
Sangman
 
Joined: 04 Feb 2020

Re: [0.4.0] "Main display" ignored in multi-monitor setup

Postby mjr4077au » Thu Apr 09, 2020 8:01 pm

Could this example code from Raymond Chen be of any help with this, or can this not be used in an OpenGL context?
User avatar
mjr4077au
 
Joined: 17 Jun 2019
Location: Gosford NSW, Australia
Discord: mjr4077au#1027
Github ID: mjr4077au
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Bugs

Who is online

Users browsing this forum: CBM and 1 guest