Wrong camera area

These bugs are specific to the SoftPoly backend

Moderator: GZDoom Developers

Wrong camera area

Postby drfrag » Thu Nov 26, 2020 12:38 pm

Top part of the camera area is not drawn and shown in black, it depends on scaled resolution.
Screenshot_Doom_20201126_192007.png
You do not have the required permissions to view the files attached to this post.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Wrong camera area

Postby drfrag » Thu Nov 26, 2020 4:08 pm

I've noticed it also happens with OpenGL and software render modes, but you see the top area instead of the bottom.
May be it's related to this: viewtopic.php?f=2&t=70565
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Wrong camera area

Postby drfrag » Fri Nov 27, 2020 11:16 am

It's not related this always happened in SoftPoly. The software modes bug happens since 4.2.1 (you only see the top part of the camera area and below a different texture), before it crashed.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Wrong camera area

Postby SanyaWaffles » Fri Nov 27, 2020 11:57 am

So this has been an issue for some time. I see now what you were saying in the other thread.

This looks like a major bug considering it affects all three renderers in different ways.
User avatar
SanyaWaffles
Witnessing perfection...
 
Joined: 25 Apr 2013
Location: Eastern Ohio
Discord: SanyaWaffles#5095
Twitch ID: sanyawaffles
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Wrong camera area

Postby drfrag » Fri Nov 27, 2020 12:26 pm

I think these are actually different bugs.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666


Return to SoftPoly2 Bugs

Who is online

Users browsing this forum: No registered users and 0 guests