Color settings not applied automatically

Bugs with GZDoom Vintage builds. Same rules apply as with all other bug reports fora.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Color settings not applied automatically

Postby bLUEbYTE » Mon Dec 02, 2019 9:06 pm

Hi,
I recently switched to LZDoom from GZDoom as it performs better on my system at high resolutions. Just discovered an issue though, where color settings like contrast don't get applied automatically. They are saved in the .ini and when I go to display settings, I can see the values set correctly. However, only after playing with one of the sliders for contrast, saturation etc. do I see the changes. Unfortunately the screenshots do not show any difference so they were useless to provide here.

So, this is how I reproduced this bug:
- Launch LZDoom with -warp switch to go into a map directly
- Observe that the colors are relatively washed out and lacking in vividness
- Modify the slider for contrast from 1.1 to 1.05, and it takes effect immediately, increasing the contrast visibly.

Because the contrast value was already at 1.1, turning it down a notch should have decreased the visible contrast rather than increasing.

Also, the saturation slider does not seem to have any effect.

System specs are Windows 10 x64 running LZDoom v3.83a. GFX card is Intel Iris Plus 655.

.ini file attached.
Attachments
lzdoom-A.ini
(25.77 KiB) Downloaded 2 times
bLUEbYTE
 
Joined: 15 Nov 2019
Location: Australia
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel with Vulkan Support

Re: Color settings not applied automatically

Postby bLUEbYTE » Mon Dec 02, 2019 11:54 pm

Found a workaround. I came across this post viewtopic.php?f=7&t=63347#p1088300 which explains the different vid_hwgamma settings. Setting it to 1 makes the game apply color settings automatically. Because the previous setting of 2 means it was relying on the driver to do the adjustments (I'm always running in fullscreen), maybe it was the driver's fault.
bLUEbYTE
 
Joined: 15 Nov 2019
Location: Australia
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel with Vulkan Support

Re: Color settings not applied automatically

Postby Rachael » Tue Dec 03, 2019 1:42 am

vid_hwgamma is something that I removed from the GZDoom mainline (it's hard-set to "1" now).

But for LZDoom, here's what the actual values are:

0 - Force display driver gamma
1 - Force shader gamma
2 - Display driver gamma in fullscreen only, shader in window mode

Shader gamma is more accurate, and does not destroy the color gamut in its output. With display gamma, the ugly color banding, particularly at darker colors, will become much more visible. That, and a litany of other issues is why it was ultimately removed. GZDoom no longer supports hardware that would've been unable to use shader gamma, anyhow, so there was no real benefit to keeping that old setting around.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Graphics Processor: nVidia with Vulkan support


Return to LZDoom Bugs

Who is online

Users browsing this forum: No registered users and 1 guest