[GZDoom 4.0.0] Glitchy rendering with FXAA on

Moderator: GZDoom Developers

[GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby Cacodemon345 » Tue Apr 09, 2019 11:58 pm

Turning on FXAA will cause the rendering to be glitched like this:
Image
Tested with a AMD Radeon RX 460.
Cacodemon345
 
Joined: 22 Dec 2017
Discord: Cacodemon345#9151
Github ID: Cacodemon345
Operating System: Windows Vista/7 64-bit
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby dpJudas » Wed Apr 10, 2019 8:11 am

Are you seeing this only with FXAA or does other postprocessing effects cause similar effects?
dpJudas
 
 
 
Joined: 28 May 2016

Re: [GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby Cacodemon345 » Wed Apr 10, 2019 8:11 am

dpJudas wrote:Are you seeing this only with FXAA or does other postprocessing effects cause similar effects?
Only FXAA, so far.
Cacodemon345
 
Joined: 22 Dec 2017
Discord: Cacodemon345#9151
Github ID: Cacodemon345
Operating System: Windows Vista/7 64-bit
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby dpJudas » Wed Apr 17, 2019 2:58 pm

Finally got around to test this. It doesn't happen on my computer.

Which operating system are you using?

Also, I could use some help from someone with an AMD card to try FXAA and report back. Need to narrow down what the conditions are for this to happen.
dpJudas
 
 
 
Joined: 28 May 2016

Re: [GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby Cacodemon345 » Thu Apr 18, 2019 4:23 am

dpJudas wrote:Which operating system are you using?
It happens with both Windows 10 and Windows 7.
Edit: Turning off Bloom postprocessing fixes the glitched rendering a bit, only the weapon sprites are affected.
Cacodemon345
 
Joined: 22 Dec 2017
Discord: Cacodemon345#9151
Github ID: Cacodemon345
Operating System: Windows Vista/7 64-bit
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [GZDoom 4.0.0] Glitchy rendering with FXAA on

Postby MasterBeavis » Sat May 18, 2019 2:00 am

Postprocessing is causing allot of issues for me
User avatar
MasterBeavis
 
Joined: 13 May 2019
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: ATI/AMD with Vulkan Support


Return to Vulkan Renderer Bugs

Who is online

Users browsing this forum: No registered users and 1 guest