SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Any utility that assists in the creation of mods, assets, etc, go here. For example: Ultimate Doom Builder 2, Slade, WadSmoosh, etc.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby Gez » Tue Aug 17, 2021 1:05 am

Enjay wrote:Is there a way to tell Slade what an Unknown lump is beyond just viewing it as Hex or Text?

I have a few single graphics that are actually in a ZDoom font format (from a time when it wasn't possible to simply print a PNG to the screen). Slade classifies these as uknown. So, is there a way for me to tell Slade that it's a font (or any other format lump for that matter)?

Yeah. Open the console first and use the "type" console command with them selected.

If you enter it without a parameter, it should print to the console a big ol' unsorted list of all known lump types. So you can scroll through and try to find which one fits your need. If you know what you want, you can use it directly, e.g. "type gfx_flat" to make SLADE consider the selected lumps to be flats.

SLADE will then try to validate that these could be what you tell them it is, and if that validation fails, the type will not be changed. In case it's a problem in the validator, you can add the "force" parameter to well, force the change anyway. E.g. "type gfx_flat force".

marco.nadal.75 wrote:Does anyone remember which of SKY1 SKY2 SKY3 gets assigned to which MAP range?

IIRC, SKY1 is used on MAP01-MAP11, SKY2 on MAP12-MAP20, and SKY3 on MAP21-MAP32.
Joined: 06 Jul 2007

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby Kinsie » Mon Aug 30, 2021 5:48 am

Since we can view and convert Quake-format graphics lumps and texture WADs, is there any chance of being able to convert to those formats? A lot of Quake 1 tools are sadly pretty outdated, and it'd be nice to kick them to the curb.
User avatar
Dog Days
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby NeuralStunner » Sat Sep 04, 2021 5:58 pm

The GFX format is absurdly simple, too.

Adding to this, I'd like to be able to export entire directories of lumps (with structure). Perhaps even a tool to unpack an entire archive.
User avatar
Not "Neutral"
Joined: 21 Jul 2009
Location: capital N, capital S, no space
Discord: NeuralStunner#4201
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: SLADE Discussion - Latest: v3.1.12 (26/May/2020)

Postby pfred1x » Thu Sep 09, 2021 8:22 pm

JPL wrote:Hi, I'm having trouble compiling SLADE latest on my Elementary (Ubuntu-derived) system. I get this error when I run cmake:
Code: Select allExpand view
-- cotire 1.7.9 loaded.
-- wx-config used is: /usr/bin/wx-config
-- wxWidgets version is: 3.0.4
-- gtk version is: 2
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find Lua (missing: LUA_LIBRARIES LUA_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.10/Modules/FindLua.cmake:193 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  src/CMakeLists.txt:108 (find_package)

I followed the "compiling on Ubuntu" instructions on the wiki, but they don't say anything about installing Lua libs, what else do I need?

I just compiled Slade on Debian Bullseye and this is the ldd output

$ ldd ./slade (0x00007ffffc6ab000) => /lib/x86_64-linux-gnu/ (0x00007fb53c406000) => /lib/x86_64-linux-gnu/ (0x00007fb53c3f3000) => /usr/local/lib/ (0x00007fb53c353000) => /usr/local/lib/ (0x00007fb53c338000) => /usr/local/lib/ (0x00007fb53c0bb000) => /usr/local/lib/ (0x00007fb53bfb5000) => /usr/local/lib/ (0x00007fb53bf85000) => /usr/local/lib/ (0x00007fb53b74c000) => /usr/local/lib/ (0x00007fb53b6ed000) => /usr/local/lib/ (0x00007fb53b46c000) => /lib/x86_64-linux-gnu/ (0x00007fb53b3b1000) => /lib/x86_64-linux-gnu/ (0x00007fb53b3a3000) => /lib/x86_64-linux-gnu/ (0x00007fb53b383000) => /lib/x86_64-linux-gnu/ (0x00007fb53b35b000) => /lib/x86_64-linux-gnu/ (0x00007fb53b33f000) => /lib/x86_64-linux-gnu/ (0x00007fb53b309000) => /lib/x86_64-linux-gnu/ (0x00007fb53b2dd000) => /lib/x86_64-linux-gnu/ (0x00007fb53b2a9000) => /lib/x86_64-linux-gnu/ (0x00007fb53b237000) => /lib/x86_64-linux-gnu/ (0x00007fb53b18b000) => /lib/x86_64-linux-gnu/ (0x00007fb53b0f3000) => /lib/x86_64-linux-gnu/ (0x00007fb53b0b0000) => /lib/x86_64-linux-gnu/ (0x00007fb53b04f000) => /lib/x86_64-linux-gnu/ (0x00007fb53b016000) => /lib/x86_64-linux-gnu/ (0x00007fb53a862000) => /lib/x86_64-linux-gnu/ (0x00007fb53a78e000) => /lib/x86_64-linux-gnu/ (0x00007fb53a5c1000) => /lib/x86_64-linux-gnu/ (0x00007fb53a47d000) => /lib/x86_64-linux-gnu/ (0x00007fb53a463000) => /lib/x86_64-linux-gnu/ (0x00007fb53a441000) => /lib/x86_64-linux-gnu/ (0x00007fb53a27a000) => /lib/x86_64-linux-gnu/ (0x00007fb53a175000) => /lib/x86_64-linux-gnu/ (0x00007fb53a11b000) => /lib/x86_64-linux-gnu/ (0x00007fb53a094000) => /lib/x86_64-linux-gnu/ (0x00007fb53a07f000) => /lib/x86_64-linux-gnu/ (0x00007fb53a07a000) => /lib/x86_64-linux-gnu/ (0x00007fb53a067000) => /lib/x86_64-linux-gnu/ (0x00007fb539e89000) => /lib/x86_64-linux-gnu/ (0x00007fb539d5a000) => /lib/x86_64-linux-gnu/ (0x00007fb536693000) => /lib/x86_64-linux-gnu/ (0x00007fb534df9000) => /lib/x86_64-linux-gnu/ (0x00007fb534de6000) => /lib/x86_64-linux-gnu/ (0x00007fb534d94000) => /lib/x86_64-linux-gnu/ (0x00007fb534c6f000) => /lib/x86_64-linux-gnu/ (0x00007fb534c49000) => /lib/x86_64-linux-gnu/ (0x00007fb534b06000) => /lib/x86_64-linux-gnu/ (0x00007fb534900000) => /lib/x86_64-linux-gnu/ (0x00007fb5348f3000) => /lib/x86_64-linux-gnu/ (0x00007fb5348e9000) => /lib/x86_64-linux-gnu/ (0x00007fb5346e3000) => /lib/x86_64-linux-gnu/ (0x00007fb5346ca000) => /lib/x86_64-linux-gnu/ (0x00007fb534684000) => /lib/x86_64-linux-gnu/ (0x00007fb53464a000) => /lib/x86_64-linux-gnu/ (0x00007fb5345c4000) => /lib/x86_64-linux-gnu/ (0x00007fb53453e000) => /lib/x86_64-linux-gnu/ (0x00007fb534538000) => /lib/x86_64-linux-gnu/ (0x00007fb534510000) => /lib/x86_64-linux-gnu/ (0x00007fb5342ee000) => /lib/x86_64-linux-gnu/ (0x00007fb53428f000) => /lib/x86_64-linux-gnu/ (0x00007fb534183000) => /lib/x86_64-linux-gnu/ (0x00007fb534177000) => /lib/x86_64-linux-gnu/ (0x00007fb53410e000) => /lib/x86_64-linux-gnu/ (0x00007fb533e1f000) => /lib/x86_64-linux-gnu/ (0x00007fb533dda000) => /lib/x86_64-linux-gnu/ (0x00007fb533d6c000) => /lib/x86_64-linux-gnu/ (0x00007fb533d61000) => /lib/x86_64-linux-gnu/ (0x00007fb533c78000) => /lib/x86_64-linux-gnu/ (0x00007fb533bcd000) => /lib/x86_64-linux-gnu/ (0x00007fb533bc2000) => /lib/x86_64-linux-gnu/ (0x00007fb533b95000) => /lib/x86_64-linux-gnu/ (0x00007fb533b86000) => /lib/x86_64-linux-gnu/ (0x00007fb533b47000) => /lib/x86_64-linux-gnu/ (0x00007fb53393c000) => /lib/x86_64-linux-gnu/ (0x00007fb533914000) => /lib/x86_64-linux-gnu/ (0x00007fb533851000) => /lib/x86_64-linux-gnu/ (0x00007fb533797000) => /lib/x86_64-linux-gnu/ (0x00007fb53376a000) => /lib/x86_64-linux-gnu/ (0x00007fb533749000) => /lib/x86_64-linux-gnu/ (0x00007fb53372a000) => /lib/x86_64-linux-gnu/ (0x00007fb5336f5000) => /lib/x86_64-linux-gnu/ (0x00007fb5336e1000) => /lib/x86_64-linux-gnu/ (0x00007fb533697000) => /lib/x86_64-linux-gnu/ (0x00007fb533497000) => /lib/x86_64-linux-gnu/ (0x00007fb533444000) => /lib/x86_64-linux-gnu/ (0x00007fb5333ee000) => /lib/x86_64-linux-gnu/ (0x00007fb5333dd000) => /lib/x86_64-linux-gnu/ (0x00007fb5333cf000) => /lib/x86_64-linux-gnu/ (0x00007fb5333c7000) => /lib/x86_64-linux-gnu/ (0x00007fb5333b5000) => /lib/x86_64-linux-gnu/ (0x00007fb5333ad000) => /lib/x86_64-linux-gnu/ (0x00007fb5333a1000) => /lib/x86_64-linux-gnu/ (0x00007fb533377000) => /lib/x86_64-linux-gnu/ (0x00007fb533340000) => /lib/x86_64-linux-gnu/ (0x00007fb53320f000) => /lib/x86_64-linux-gnu/ (0x00007fb5331f3000) => /lib/x86_64-linux-gnu/ (0x00007fb53310b000) => /lib/x86_64-linux-gnu/ (0x00007fb5330ba000) => /lib/x86_64-linux-gnu/ (0x00007fb532fbd000) => /lib/x86_64-linux-gnu/ (0x00007fb532fb6000) => /lib/x86_64-linux-gnu/ (0x00007fb532f31000) => /lib/x86_64-linux-gnu/ (0x00007fb532da5000) => /lib/x86_64-linux-gnu/ (0x00007fb532d50000) => /lib/x86_64-linux-gnu/ (0x00007fb532cf9000) => /lib/x86_64-linux-gnu/ (0x00007fb532c37000)
/lib64/ (0x00007fb53d7d5000) => /lib/x86_64-linux-gnu/ (0x00007fb532c30000) => /lib/x86_64-linux-gnu/ (0x00007fb532c23000) => /lib/x86_64-linux-gnu/ (0x00007fb532c1e000) => /lib/x86_64-linux-gnu/ (0x00007fb532c19000) => /lib/x86_64-linux-gnu/ (0x00007fb532bd6000) => /lib/x86_64-linux-gnu/ (0x00007fb532bcd000) => /lib/x86_64-linux-gnu/ (0x00007fb532bb6000) => /lib/x86_64-linux-gnu/ (0x00007fb532baa000) => /lib/x86_64-linux-gnu/ (0x00007fb532b4d000) => /lib/x86_64-linux-gnu/ (0x00007fb532b21000) => /lib/x86_64-linux-gnu/ (0x00007fb532b07000) => /lib/x86_64-linux-gnu/ (0x00007fb532a92000) => /lib/x86_64-linux-gnu/ (0x00007fb532a87000) => /lib/x86_64-linux-gnu/ (0x00007fb532a72000) => /lib/x86_64-linux-gnu/ (0x00007fb5328c4000) => /lib/x86_64-linux-gnu/ (0x00007fb532781000) => /lib/x86_64-linux-gnu/ (0x00007fb53273f000) => /lib/x86_64-linux-gnu/ (0x00007fb532730000) => /lib/x86_64-linux-gnu/ (0x00007fb53272b000) => /lib/x86_64-linux-gnu/ (0x00007fb53260b000) => /lib/x86_64-linux-gnu/ (0x00007fb5325f9000) => /lib/x86_64-linux-gnu/ (0x00007fb532579000) => /lib/x86_64-linux-gnu/ (0x00007fb532430000) => /lib/x86_64-linux-gnu/ (0x00007fb5323f0000) => /lib/x86_64-linux-gnu/ (0x00007fb532372000) => /lib/x86_64-linux-gnu/ (0x00007fb532332000) => /lib/x86_64-linux-gnu/ (0x00007fb532279000) => /lib/x86_64-linux-gnu/ (0x00007fb5321fd000) => /lib/x86_64-linux-gnu/ (0x00007fb5321f0000) => /lib/x86_64-linux-gnu/ (0x00007fb5321e8000) => /lib/x86_64-linux-gnu/ (0x00007fb532149000) => /lib/x86_64-linux-gnu/ (0x00007fb53213b000) => /lib/x86_64-linux-gnu/ (0x00007fb5320db000) => /lib/x86_64-linux-gnu/ (0x00007fb5320c5000) => /lib/x86_64-linux-gnu/ (0x00007fb5320be000) => /lib/x86_64-linux-gnu/ (0x00007fb5320a5000) => /lib/x86_64-linux-gnu/ (0x00007fb532075000) => /lib/x86_64-linux-gnu/ (0x00007fb532052000) => /lib/x86_64-linux-gnu/ (0x00007fb531d4c000) => /lib/x86_64-linux-gnu/ (0x00007fb531b63000) => /lib/x86_64-linux-gnu/ (0x00007fb531aae000) => /lib/x86_64-linux-gnu/ (0x00007fb531aa1000) => /lib/x86_64-linux-gnu/ (0x00007fb5319f6000) => /lib/x86_64-linux-gnu/ (0x00007fb5319f1000) => /lib/x86_64-linux-gnu/ (0x00007fb5319c6000) => /lib/x86_64-linux-gnu/ (0x00007fb5319b7000) => /lib/x86_64-linux-gnu/ (0x00007fb5317ab000) => /lib/x86_64-linux-gnu/ (0x00007fb53178d000) => /lib/x86_64-linux-gnu/ (0x00007fb531784000) => /lib/x86_64-linux-gnu/ (0x00007fb531755000) => /lib/x86_64-linux-gnu/ (0x00007fb53167a000) => /lib/x86_64-linux-gnu/ (0x00007fb53146a000) => /lib/x86_64-linux-gnu/ (0x00007fb53144e000) => /lib/x86_64-linux-gnu/ (0x00007fb531218000) => /lib/x86_64-linux-gnu/ (0x00007fb5311b5000) => /lib/x86_64-linux-gnu/ (0x00007fb531175000) => /lib/x86_64-linux-gnu/ (0x00007fb53115b000) => /lib/x86_64-linux-gnu/ (0x00007fb531151000) => /lib/x86_64-linux-gnu/ (0x00007fb53113f000) => /lib/x86_64-linux-gnu/ (0x00007fb530fbd000) => /lib/x86_64-linux-gnu/ (0x00007fb530f74000) => /lib/x86_64-linux-gnu/ (0x00007fb530ef1000) => /lib/x86_64-linux-gnu/ (0x00007fb530dbd000) => /lib/x86_64-linux-gnu/ (0x00007fb530ce3000) => /lib/x86_64-linux-gnu/ (0x00007fb530cb3000) => /lib/x86_64-linux-gnu/ (0x00007fb530cad000) => /lib/x86_64-linux-gnu/ (0x00007fb530c9c000) => /lib/x86_64-linux-gnu/ (0x00007fb530c7f000) => /lib/x86_64-linux-gnu/ (0x00007fb530c5c000) => /lib/x86_64-linux-gnu/ (0x00007fb530c25000) => /lib/x86_64-linux-gnu/ (0x00007fb530bf9000) => /lib/x86_64-linux-gnu/ (0x00007fb530ba3000) => /usr/lib/x86_64-linux-gnu/pulseaudio/ (0x00007fb530b1f000) => /lib/x86_64-linux-gnu/ (0x00007fb530ac4000) => /lib/x86_64-linux-gnu/ (0x00007fb530abf000) => /lib/x86_64-linux-gnu/ (0x00007fb530aab000) => /lib/x86_64-linux-gnu/ (0x00007fb530a9b000) => /lib/x86_64-linux-gnu/ (0x00007fb530a6a000) => /lib/x86_64-linux-gnu/ (0x00007fb530a19000) => /lib/x86_64-linux-gnu/ (0x00007fb530981000) => /lib/x86_64-linux-gnu/ (0x00007fb53097c000) => /lib/x86_64-linux-gnu/ (0x00007fb530954000) => /lib/x86_64-linux-gnu/ (0x00007fb530939000) => /lib/x86_64-linux-gnu/ (0x00007fb530890000) => /lib/x86_64-linux-gnu/ (0x00007fb53080c000) => /lib/x86_64-linux-gnu/ (0x00007fb530805000) => /lib/x86_64-linux-gnu/ (0x00007fb5307fe000) => /lib/x86_64-linux-gnu/ (0x00007fb5307f1000) => /lib/x86_64-linux-gnu/ (0x00007fb5307d3000) => /lib/x86_64-linux-gnu/ (0x00007fb52ecba000) => /lib/x86_64-linux-gnu/ (0x00007fb52ec97000) => /lib/x86_64-linux-gnu/ (0x00007fb52ec8b000) => /lib/x86_64-linux-gnu/ (0x00007fb52ec86000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea80000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea69000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea62000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea54000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea4c000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea31000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea24000) => /lib/x86_64-linux-gnu/ (0x00007fb52ea07000) => /lib/x86_64-linux-gnu/ (0x00007fb52e9d8000)

To find out where all of that comes from you can do an apt-file search of each file name.
That will return packages those files may come from. Then it is guess your best.
Every time cmake bombs it gives you little clues what it is looking for. My strategy is to
keep plugging away and try to satisfy deps as they pop up.

Some installs I recorded doing:
(use aptitude install to drag in other dependencies)

There were other things I installed from source too because the versions in the repo were too old.
Like wxWidgets. Some things I installed were so I could build it. So you may not need everything I
had to install. My notes file for installing Slade is 944 lines long and I just grepped "aptitude install"
to make that list. Also I've built a number of other source packages on my PC previously so I had a lot of dev
packages installed already. So none of that would show up in my Slade notes. The ldd list is the master
list of all of Slade's deps. You're going to need the lib and dev packages of all of that. It is quite a long list.

$ ldd slade | wc -l

Once you get Slade running you're going to find out that you need other helper apps. Like a BSP thingie.
I compiled something called GLBSP. Although I'm not sure if it is doing what it should do. I could not get into
the map I made using the tutorial. Today was the first day I ever tried using Slade. So far not so good.
Which is a large part of why I am here. I have questions myself. Good luck!
Joined: 18 Oct 2017

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby Enjay » Mon Sep 13, 2021 4:02 pm

I'd had an ISO of a CD mounted and had used Slade to look inside a PAK file inside the ISO.

Later, when the ISO was unmounted, I tried to start Slade simply by double clicking the exe. Slade popped up a message saying that it couldn't start and listed the PAK file as the problem.

All I had to do was go into my appdata and delete the file history entry for that file and Slade could start. (Fortunately I knew to look there.)

Slade doesn't normally refuse to start when a previously opened file is missing so, after a little digging, I think that the problem is that the file path was to a drive that doesn't exist once the ISO is unmounted. So, I tried putting spurious file names into the cfg. As long as the drive existed, Slade would open (and on closing the spurious file would disappear from the recent file list in the cfg file) but if I put any file name in with a path to a non-existent drive, Slade refused to start.


Short version, if Slade has a recent file in its config that is on a drive that doesn't currently exist on the machine, Slade will refuse to open.

Can Slade be changed so that it treats such paths in the same way as it does files that no longer exist? - i.e. open normally and erase the reference to the file in the recent file list.
User avatar
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
Joined: 15 Jul 2003
Location: Scotland

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby nova++ » Fri Sep 17, 2021 7:36 pm

Rather than continue to annoy everyone on the github issues page, I'll babble about some stuff I've been encountering over here...

I've been having issues with the linux version of slade's map editor just being choppy and unresponsive and generally kind of unhappy. It's not unusable, but it's not super great either. It's inconsistent, though. And it also is a lot better when I've tried it on different hardware - in this case, my ryzen 2200G seems to digest it much better than my ryzen 1700. The latter also has a GTX 1070 and nvidia has kind of a reputation when it comes to linux drivers, so maybe that has something to do with it, too... I have my own build of it with a few quick hax for my own uses but I don't think that has much to do with it (same build on both systems anyway). Plenty of background stuff going on in the 2200G system too, and it still just feels generally more responsive. It's weird.

It runs a lot better under wine, meanwhile, super fluid and responsive in the editor. Of course, the file browsing is a nightmare and a lot of the UI is kinda wonky under wine, but I guess it's something...

I dunno what to do with this information though, or if it's any use to anyone else.

Edit: I made a comparison between the two. It tends to get worse over time on linux (as per ) and this is after letting it sit for a while. Make sure youtube is playing at 60fps when watching, otherwise it hides the stutters

(there are some slight differences between these builds as the native one is my own with as mentioned earlier, but it's nothing that would affect it so much. later I will make a windows build with the same changes and try that too, but I don't expect much)
User avatar
Real life space alien (not fake)
Joined: 04 Sep 2021
Operating System: Other Linux 64-bit

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby Rowsol » Sat Nov 27, 2021 2:22 pm

For some reason, over night, Slade has started to freeze whenever I look at a graphic. I've tried 2 version and it happens on both. Is there a reset option?

Resetting my PC stopped the freezing and I found the .cfg file in Appdata, because of course it's there.
User avatar
Joined: 06 Mar 2013

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby CJacobsLP » Fri Dec 03, 2021 3:02 am

Not sure where this belongs at all because I think it's intended behavior, but splitting lines does not seem to align the resulting vertex to the grid even with grid snapping enabled. As far as I can tell there's no way to make that so. Is there one that I've missed?
Joined: 03 Dec 2021

Re: SLADE Discussion - Latest: v3.1.13 (01/Jun/2021)

Postby Kappes Buur » Fri Dec 03, 2021 12:25 pm

CJacobsLP wrote:....., but splitting lines does not seem to align the resulting vertex to the grid even with grid snapping enabled. As far as I can tell there's no way to make that so. .....

does work with slade_3.2.0_b3.
User avatar
Kappes Buur
Joined: 17 Jul 2003
Location: British Columbia, Canada


Return to Creation, Conversion, and Editing

Who is online

Users browsing this forum: No registered users and 0 guests