SLADE Discussion - Latest: v3.1.12 (26/May/2020)

Any utility that assists in the creation of mods, assets, etc, go here.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby Kinsie » Mon Feb 24, 2020 10:21 am

Text hilighting on plaintext lumps with the "None" text language type is bugged, inheriting all the hilighting from whatever text lump was previously selected.

Image
User avatar
Kinsie
Dog Days
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby SanyaWaffles » Mon Feb 24, 2020 5:36 pm

Can confirm this happens in Slade version as well.
User avatar
SanyaWaffles
Navy Did Nothing Wrong
 
Joined: 25 Apr 2013
Location: Eastern Ohio
Discord: SanyaWaffles#5095
Twitch ID: sanyawaffles
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby Hexereticdoom » Mon Feb 24, 2020 8:12 pm

Recently I have updated to v3.1.10 and seems there is an issue with the Entries section, to be precise with the (sort by) Name button, which has stopped to work with the directories/folders list from PK3 and ZIP archives... :?

The rest of listed entries are normally sorted by name toggling the button, just the directories are the only ones unaffected. On previous versions this didn't happen.
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby irontusk341 » Wed Feb 26, 2020 9:18 pm

i havent updated to 3.1.10 yet... should i wait until another patch?
User avatar
irontusk341
Main Author & Director of Diablo 3D: A Heretic mod based on the Diablo Games
 
Joined: 10 Oct 2017
Location: Mister Rogers Neighborhood, Pennsylvania
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia (Modern GZDoom)

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby sirjuddington » Wed Feb 26, 2020 10:42 pm

irontusk341 wrote:i havent updated to 3.1.10 yet... should i wait until another patch?

If you're on 3.1.9 I would update (it has a pretty major issue), otherwise you can wait (I'll be releasing 3.1.11 in the near future, probably)
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby Marisa Kirisame » Tue Mar 03, 2020 9:07 am

I updated to 3.1.10 recently and I've noticed that folders don't get properly sorted alphabetically. Files do, though.
Image

Actually nvm about that, didn't notice someone reported it already.

Well then, the other issue I have is that syntax highlighting has stopped working ENTIRELY on Linux. Also that before being gone, back with 3.1.8, syntax highlighting BROKE entirely whenever non-ascii characters were involved.
User avatar
Marisa Kirisame
ZScript Crimester
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: 霧雨魔理沙#1666
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.10 (20/Feb/2020)

Postby sirjuddington » Tue Mar 03, 2020 6:50 pm

3.1.11 is up now which should fix a few issues that were reported.

Marisa Kirisame wrote:Well then, the other issue I have is that syntax highlighting has stopped working ENTIRELY on Linux. Also that before being gone, back with 3.1.8, syntax highlighting BROKE entirely whenever non-ascii characters were involved.

Hopefully 3.1.11 fixes the syntax highlighting not working.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Marisa Kirisame » Wed Mar 04, 2020 6:56 am

Well, I just updated and now something weird is happening. Files with '\' in the name are being converted into folders automatically.
User avatar
Marisa Kirisame
ZScript Crimester
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: 霧雨魔理沙#1666
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Gez » Wed Mar 04, 2020 8:01 am

Marisa Kirisame wrote:Files with '\' in the name


Why are you doing this.


Also I'm pretty sure it's standard behavior for zips. \ and / are path separators. I experimented with this kind of things using a hex editor to change filenames in a zip file.
Gez
 
 
 
Joined: 06 Jul 2007

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Marisa Kirisame » Wed Mar 04, 2020 8:49 am

Well I mean, sometimes my sprite frames go all the way to [\]. I thought that was perfectly normal. Plus I didn't have any issues before.

Guess that's two unix-isms SLADE has trouble with now. Until now it was just the whole thing about being unable to change the casing of a filename because it thinks it's "the same file".
User avatar
Marisa Kirisame
ZScript Crimester
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: 霧雨魔理沙#1666
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Gez » Wed Mar 04, 2020 8:56 am

ZDoom supports using ^ in file names instead of \.
Gez
 
 
 
Joined: 06 Jul 2007

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Marisa Kirisame » Wed Mar 04, 2020 8:59 am

Ah, thank you. I'll do that. It is important for compatibility with inferior OSes after all. :P
User avatar
Marisa Kirisame
ZScript Crimester
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: 霧雨魔理沙#1666
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Graf Zahl » Wed Mar 04, 2020 9:06 am

Linux surely is inferior if it cannot deal with Zips made for DOS. :P :twisted:
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Marisa Kirisame » Wed Mar 04, 2020 10:39 am

I've never had any trouble with those myself, Graf-senpai.

Anyway, more on other issues:
- The "*" next to the name of a tab doesn't go away after saving, seems to only happen with folders though.
- Copying and pasting files has this weird thing where the "clipboard" doesn't get cleared when selecting something else, so it pastes duplicates of previously copied files.
User avatar
Marisa Kirisame
ZScript Crimester
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: 霧雨魔理沙#1666
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Postby Gothic » Wed Mar 11, 2020 7:13 pm

Slade has a problem playing 4-bit wav files, they don't play automatically like a 16-bit wav file or an ogg.
User avatar
Gothic
To be fair, you have to have a very high IQ to understand ZScript.
 
Joined: 17 Jun 2011
Location: Where it all began...
Discord: #1462

PreviousNext

Return to Editors / Asset Manipulation

Who is online

Users browsing this forum: No registered users and 1 guest