SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Any utility that assists in the creation of mods, assets, etc, go here.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: SLADE Discussion - Latest: v3.1.5 (07/May/2019)

Postby irontusk341 » Sun Oct 06, 2019 9:55 pm

sirjuddington wrote:
irontusk341 wrote:pk3's greater than 800mb (Like HD or 4K textures) cannot be loaded into Slade without Errors

You'll need to use the 64bit version to open anything very large, as 32bit has memory usage constraints (64bit does too but they are significantly larger).


The issues with the text editor should be fixed in the next release, they are caused by a bug in wxWidgets 3.1.2 - I've rolled it back to 3.1.1 on my system which doesn't have the bug.

There also seems to be an issue with the website since mancubus.net was moved. I'm not sure what is wrong since other mancubus.net websites work fine (including my personal one), just not SLADE. In the meantime releases are still available on GitHub if anyone needs them.


tested it on 3.1.6 x64 bit.. the 1.5GB 4k texture pack loads up.. Thanks!!
User avatar
irontusk341
Main Author & Director of Diablo 3D: A Heretic mod based on the Diablo Games
 
Joined: 09 Oct 2017
Location: Pennsylvania

Re: SLADE Discussion - Latest: v3.1.5 (07/May/2019)

Postby sirjuddington » Mon Oct 07, 2019 3:23 am

3.1.7 is up (on GitHub only for now) - it should fix most of the text editor issues people were having, among other things.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Kinsie » Tue Oct 08, 2019 6:16 am

Many thanks for these fixes!
User avatar
Kinsie
A Concept Utterly Obsolete
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Kinsie » Tue Oct 08, 2019 6:55 pm

Posting again with a minor bug report: Several sprites in HEXEN.WAD are being falsely detected as SRB2 Encore lumps instead of Doom format graphics.
User avatar
Kinsie
A Concept Utterly Obsolete
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Kappes Buur » Wed Oct 09, 2019 12:22 pm

3.1.7 gives me severe headaches.
Opened a map in the 64bit version, added a couple of scripts and a MAPINFO.
Saved and opened in GZDBBF and no map was found.
Also does not play some sound formats, like mus and mp3.

Spoiler:


Reverting to 3.1.6.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia Canada

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Kinsie » Fri Oct 11, 2019 5:47 am

Kappes Buur wrote:Also does not play some sound formats, like mus and mp3.

Spoiler:

THE START PAGE wrote:The 64bit build currently doesn't support MIDI playback via fluidsynth (you'll have to set up and use timidity instead for now)
Both specified formats work fine for me.
User avatar
Kinsie
A Concept Utterly Obsolete
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Kappes Buur » Fri Oct 11, 2019 7:16 pm

Kinsie wrote:Both specified formats work fine for me.


Thank you
The 32 bit version of 3.1.7 seems to work just fine.

One other thing:
Running 3.1.7 I no longer showed the icon (green triangle) for test map.
However, that, after a bit of floundering about, was solved by deleting the old slade3.cfg of 3.1.6 and let 3.1.7 create a new slade3.cfg.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia Canada

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby zhadoom » Fri Oct 18, 2019 9:49 am

Kinsie wrote:Posting again with a minor bug report: Several sprites in HEXEN.WAD are being falsely detected as SRB2 Encore lumps instead of Doom format graphics.


I'd like to add the following:
Importing an PNG can falsely generate an SRB2 lump entry.
I tried this with PNG files saved by the program Awesomebump. They became SRB2 entries in SLADE.
In contrast, after saving the same file with Paint, they became PNG entries in SLADE.

Apart from that, I havn't noticed any other bugs in 3.1.7 up to now.
Hence a bin THANK YOU for the update! :D

Kind regards
zhd
zhadoom
 
Joined: 04 Feb 2019

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Quantum3113 » Sat Oct 19, 2019 3:24 pm

Would just like to report that the text editor issues are still present in the 3.1.7 release. Everything inside quotations is red still. Is there anyway you could reupload of 3.0.0.
Quantum3113
 
Joined: 11 May 2019

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Gez » Sat Oct 19, 2019 5:39 pm

Quantum3113 wrote:Is there anyway you could reupload of 3.0.0.


https://github.com/sirjuddington/SLADE/releases
You can go as far back as 3.1.0 beta 1, from 2013.

You probably don't actually want 3.0.0.
Gez
 
 
 
Joined: 06 Jul 2007

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Quantum3113 » Sat Oct 19, 2019 6:27 pm

Gez wrote:
Quantum3113 wrote:Is there anyway you could reupload of 3.0.0.


https://github.com/sirjuddington/SLADE/releases
You can go as far back as 3.1.0 beta 1, from 2013.

You probably don't actually want 3.0.0.


Thanks For the quick reply. Ill Give some of them older ones a try.

EDIT* For anyone curious Slade 3.1.1.5 is the earliest version i could find that doesnt have the text editor issues. Heres link to that version.

https://github.com/sirjuddington/SLADE/ ... ag/3.1.1.5
Quantum3113
 
Joined: 11 May 2019

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby sirjuddington » Sun Oct 20, 2019 5:43 pm

Quantum3113 wrote:Would just like to report that the text editor issues are still present in the 3.1.7 release. Everything inside quotations is red still. Is there anyway you could reupload of 3.0.0.

What issue exactly are you referring to here? I don't remember anything reported to do with quotations - the only known issue is commented out text colours not updating correctly in certain situations.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Quantum3113 » Mon Oct 21, 2019 12:56 am

sirjuddington wrote:
Quantum3113 wrote:Would just like to report that the text editor issues are still present in the 3.1.7 release. Everything inside quotations is red still. Is there anyway you could reupload of 3.0.0.

What issue exactly are you referring to here? I don't remember anything reported to do with quotations - the only known issue is commented out text colours not updating correctly in certain situations.


Yeah i believe thats what im referring to for example.

//==============
//==Decorations-->
//==============

#include "Hell.DEC"
#include "Nature.DEC"
#include "Tech.DEC"
#include "Torches.DEC"
#include "Barrels.DEC"

Everything inside the quotations is a blistering red. Im rather novice with decorate and learning so dont really have the nomiclature.
Quantum3113
 
Joined: 11 May 2019

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby DabbingSquidward » Mon Oct 21, 2019 2:44 am

I think that's intentional, everything between quotation marks is treated as a string. Btw, under options you should be able to choose between different themes and select individual colors for everything. Last but not least, what gets colored is depending on the selected definition language, but strings should be red in all of them by default, hope I could help:D

Edit: Most of the time you don't need to put text into quotation marks, except if it contains one or more spaces. But it's better to stick to it.
User avatar
DabbingSquidward
Donut eat me pls!
 
Joined: 08 Nov 2017
Location: Germany
Operating System: Windows Vista/7 64-bit
Graphics Processor: nVidia with Vulkan support

Re: SLADE Discussion - Latest: v3.1.7 (07/Oct/2019)

Postby Tartlman » Mon Oct 21, 2019 9:28 am

Would it be possible to have unknown files open as text files by default, as an option?

Since SLADE doesn't seem to recognize ACS source files and ZScript files in folders, I'm finding that it's really tedious to open a file, insert a random space, deleting said random space, and saving over the entire archive just so it automatically opens as text.

Also, another strange bug is that the first time you open an unknown file type as text there is a large, empty space above the text editor.

I'm using 3.1.6
User avatar
Tartlman
shitposting with zscript
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

PreviousNext

Return to Editors / Asset Manipulation

Who is online

Users browsing this forum: No registered users and 1 guest