Page 178 of 188

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Wed May 23, 2018 2:57 pm
by MartinHowe
I am looking at giving up in despair on SLADE3. Crash, crash, crash. I can live with the occasional crash, in a beta, but there are no stable Linux builds available from the SLADE3 website and installing SLADE3 from the DRD repo also yields the beta. The instructions for building SLADE on Ubuntu are way out of date and the suggestions don't work.

I realise that SJ is doing all of this on his own time and not making money out of it, so do appreciate it will be a while before anything happens. However, this leaves me without a working map editor. I have at least got GZDB to work in a Windows VM, but it is slow even on my gaming rig and there are too many artefacts using ZDoom in the VM; I'm amazed they work at all :)

So in the meantime, does anyone have a copy of the last stable version of SLADE3 executable file from a debian based Linux distro that they could post here?

EDIT: And for the EVULZ, I got SLADE3 and ZDoom windows versions working in WINE and they are faster and less flaky than the VM! If there is a God, he's barking mad :p

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Mon May 28, 2018 7:25 pm
by irontusk341
I have noticed slade 3.1.2 is that the larger the pk3 file, the more it crashes when accessing PNG versions of Textures or Flats.

i have been running into this problem more frequently as i make a 4k Texture pack for Heretic.

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Wed May 30, 2018 10:56 am
by sk1re
@MartinHowe
I have a Slade 3.1.2 beta5 executable for every major Linux x64 distro. (package contains binary+dependencies)
Simply unzip and launch the script "run_slade.sh" - no installation required.
Download:
http://www.mediafire.com/file/px944av3t ... 3.zip/file ~52MB

hf,
sk1re

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Wed May 30, 2018 3:52 pm
by MartinHowe
Thanks, for the offer; sadly, I already have that from DRD repo. What I would like to try is if anyone still has a copy of the last *stable* version (not a beta).

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Wed May 30, 2018 10:02 pm
by Caligari87
You can actually get all past builds that the repo hosted, here: http://debian.drdteam.org/pool/multiverse/s/slade/

I think 3.1.1.5 was maybe the last technically "stable" version but stable is relative (the current beta is fine for me), 3.1.2 has had several betas since the middle of last year and I presume one of them was working for you until relatively recently.

8-)

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Thu May 31, 2018 6:13 pm
by MartinHowe
Thanks, I'll have a look :)

Actually, I have not done any mapping for about 18 months and have only recently started again; in other words, for the first time since moving to Linux -- i.e. where DoomBuilder does not exist ... so am acutally a SLADE n00b :p I'm dreading yet another learning curve; I have used SLADE as a lump editor/wad tool in the past but not for mapping, so this will be a new one. I really do want to to give SLADE a chance, but it needs to be stable enough for me to do so.

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Jun 17, 2018 3:56 pm
by Silentdarkness12
Compiled a USDF script and put it into a wad. Slade thinks it's a Build graphics, and won't let me save it.

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Jun 17, 2018 6:23 pm
by Gez
Can you upload the file for testing?

In the meantime, unless you're targeting vanilla Strife compatibility, you can use the source in your mod, GZDoom can read those just fine.

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Jun 17, 2018 6:27 pm
by Silentdarkness12
.o extension is not allowed, so i'm just attatching the text file.

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Jun 17, 2018 8:04 pm
by Gez
.zip extension is allowed...

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Aug 12, 2018 7:30 am
by CWolf
Guess I need some help.

Zoom slider went nowhere. Which is strange since I did nothing for it happened.

How to fix that?

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sun Sep 09, 2018 5:18 pm
by ThrashfanBert1994
i have a suggestion, able to open the Ipk3

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Tue Sep 11, 2018 10:50 am
by wildweasel
ThrashfanBert1994 wrote:i have a suggestion, able to open the Ipk3

It already can, just the Open dialogue doesn't list it as a "supported" extension. Set it to show All Files and pick the .ipk3 and it should open fine. (Or do what I do, and click/drag the file from an Explorer window into Slade's window.)

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sat Sep 15, 2018 4:37 pm
by Void Weaver
Hi there.

Nor in Slade 3.1.1.5 nor in 3.1.2 Beta 5, functions GiveBody and SpawnHealth aren't highlighted and returns errors "Invalid parameter 'givebody'\'spawnhealth'" despite the wiki says those both are decorate functions.


EDIT:
Gez are absolutely right, I am so stupid, sorry. :oops:

Re: SLADE Discussion - Latest: v3.1.2 Beta 5 (11/Sep/2017)

PostPosted: Sat Sep 15, 2018 4:44 pm
by Gez
It's not SLADE that gives you this error message, it's GZDoom.

There's nothing magical about SLADE and DECORATE. DECORATE is just a text format. You could use notepad instead. Whether SLADE highlights a keyword or not changes nothing as far as whether it works in the engine or not.