SLADE Discussion - Latest: v3.1.11 (04/Mar/2020)

Any utility that assists in the creation of mods, assets, etc, go here.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: SLADE3 beta (testing release, beta5 up)

Postby jdtm » Wed Jun 02, 2010 10:49 pm

lol i cant get this to install on ubuntu 10.04:
slade wants freeimage and wxwidgets :|
i got freeimage to install :)
but wxwidget wants gtk+2 :|
gtk2+ wants glib, pango, atk, and cario :(
glib spits this out:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. :evil:
sorry, too much trouble.

So i wine'd it :D
It looks pretty promising. Kinda distorted the view of bitmaps in my wad, but the pngs looked fine, but I'm guessing its a wine issue. Cant wait for a final.
jdtm
 
Joined: 27 Mar 2010

Re: SLADE3 beta (testing release, beta5 up)

Postby japboy » Thu Jun 03, 2010 1:19 am

im using slade 3.0 and 2.0 on ubuntu 10.04 currently. they work fine.
actually i got some trouble to build wxWidgets. it must be 2.9.0 for slade 3.0, and 2.8.11 for slade 2.0 on ubuntu 10.04.

and must grab MesaLib before building wx-2.9:
Code: Select allExpand view
sudo aptitude install libgl1-mesa-dev libglu1-mesa-dev


remember to configure wx-2.9 with --with-opengl:
Code: Select allExpand view
./configure --with-gtk --with-opengl
make
sudo make install


afterwards, building slade 3.0 finished successfully for me.

* slade 2.0 on ubuntu amd64 doesn't seem to work. it should be compiled as 32 bit application.
User avatar
japboy
 
Joined: 26 Mar 2010
Location: Tokyo, JAPAN

Re: SLADE3 beta (testing release, beta5 up)

Postby Virtue » Sat Jun 05, 2010 10:43 am

I get 2 errors opening up SLADE:

Genport I/O Initialization Failure.
grSstSelect: non-existent SST
User avatar
Virtue
We Stand to Fight
 
Joined: 19 Nov 2006
Location: Manchester UK

Re: SLADE3 beta (testing release, beta5 up)

Postby ZDG » Sat Jun 05, 2010 10:57 am

jdtm wrote: Kinda distorted the view of bitmaps in my wad

Never, ever use BMP's in wad, it breaks it. see this.
User avatar
ZDG
NEOMARINE
 
Joined: 02 Jan 2010
Location: in SlumpEd

Re: SLADE3 beta (testing release, beta5 up)

Postby InsanityBringer » Sat Jun 05, 2010 11:37 am

I'm going to assume he means plain doom graphics. It's just that the convention that editors mostly work with BMPs (set by XWE and WinTex) confuses some.
User avatar
InsanityBringer
 
Joined: 05 Jul 2007
Location: opening the forbidden box
Discord: InsanityBringer#9908

Re: SLADE3 beta (testing release, beta5 up)

Postby sirjuddington » Sun Jun 06, 2010 8:44 pm

Ben2k9 wrote:I get 2 errors opening up SLADE:

Genport I/O Initialization Failure.
grSstSelect: non-existent SST

I have absolutely no idea what would cause that.

Edit: upon looking it up, it seems to be caused by old 3dfx video drivers. Do you happen to have an opengl32.dll file in the same folder as SLADE?
Last edited by sirjuddington on Sun Jun 06, 2010 9:18 pm, edited 1 time in total.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE3 beta (testing release, beta5 up)

Postby sirjuddington » Sun Jun 06, 2010 9:15 pm

jdtm wrote:lol i cant get this to install on ubuntu 10.04:
slade wants freeimage and wxwidgets :|
i got freeimage to install :)
but wxwidget wants gtk+2 :|
gtk2+ wants glib, pango, atk, and cario :(
glib spits this out:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. :evil:
sorry, too much trouble.

Did you follow the instructions in README-unix? It's pretty simple to compile in linux, especially ubuntu. You shouldn't need to compile gtk or anything, just get the packages.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE3 beta (testing release, beta5 up)

Postby Virtue » Mon Jun 07, 2010 4:15 am

sirjuddington wrote:
Ben2k9 wrote:I get 2 errors opening up SLADE:

Genport I/O Initialization Failure.
grSstSelect: non-existent SST

I have absolutely no idea what would cause that.

Edit: upon looking it up, it seems to be caused by old 3dfx video drivers. Do you happen to have an opengl32.dll file in the same folder as SLADE?

I got it working, I had to put it in a seperate folder from my Doom ones, I think it was a problem with conflicting drivers yeah.
User avatar
Virtue
We Stand to Fight
 
Joined: 19 Nov 2006
Location: Manchester UK

Re: SLADE3 beta (testing release, beta5 up)

Postby jdtm » Thu Jun 10, 2010 8:33 pm

sirjuddington wrote:
jdtm wrote:lol i cant get this to install on ubuntu 10.04:
slade wants freeimage and wxwidgets :|
i got freeimage to install :)
but wxwidget wants gtk+2 :|
gtk2+ wants glib, pango, atk, and cario :(
glib spits this out:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. :evil:
sorry, too much trouble.

Did you follow the instructions in README-unix? It's pretty simple to compile in linux, especially ubuntu. You shouldn't need to compile gtk or anything, just get the packages.


Of course i read the README-unix. How else would i know that it needed wxwidget and freeimage. According to the readme, WxWidgets needs to be version 2.9+, and when i went to the website to get it (because 2.9+ wasnt in synaptic) and so far their latest version is the 2.90 development snapshot. i downloaded it and went to build it, and it gave me all the mumbo-jumbo from above.
I'll admit that I'm not as good with Linux as other people.

ZDG wrote:Never, ever use BMP's in wad, it breaks it. see this.

umm...bmp's have been working just fine. I can load a 256color bmp into a wad with xwe and it works fine.
What I was saying is that when i viewed a WAD that did have bitmaps in it with the slade beta, it distorted their view in the preview window.
jdtm
 
Joined: 27 Mar 2010

Re: SLADE3 beta (testing release, beta5 up)

Postby NeuralStunner » Thu Jun 10, 2010 8:38 pm

jdtm wrote:umm...bmp's have been working just fine. I can load a 256color bmp into a wad with xwe and it works fine.

XWE actually converts them to DooM GFX format. AFAIK normal bitmap is useless in ZDoom. (At least for things that should have transparency.)
User avatar
NeuralStunner
An Exercise in Self-Indulgence
 
 
 
Joined: 21 Jul 2009
Location: Indiana, USA
Discord: NeuralStunner#1293
Operating System: Windows Vista/7 64-bit

Re: SLADE3 beta (testing release, beta5 up)

Postby Gez » Thu Jun 10, 2010 9:00 pm

NeuralStunner wrote:
jdtm wrote:umm...bmp's have been working just fine. I can load a 256color bmp into a wad with xwe and it works fine.

XWE actually converts them to DooM GFX format. AFAIK normal bitmap is useless in ZDoom. (At least for things that should have transparency.)

For everything. BMP are not among the supported data formats.

XWE and SLumpEd/SLADE have different philosophies:

The XWE philosophy: assume you're smarter than the user and second-guess what he wants to do. He puts a trucolor PNG in a wad, which uses a wide range of ligth blues? Well obviously he wants it converted to the Dom GFX format and palette-raped. Let's do the conversion automatically! If the user didn't want it, he'd have went for the "import as raw data" option that is hidden somewhere...

The Slumped/Slade philosophy: do what the user tells, nothing more, nothing less. He puts a BMP in a wad, well, maybe he has good reasons for that. If he wants to convert it, he can do it, but that's a different operation. Importing or exporting does not imply a conversion.

I honestly prefer the Slumped/Slade approach a thousand times. It is a lot more reasonable and a lot more sane when you mod for an engine like ZDoom which supports many different data formats, not just the few used natively by Doom.
Gez
 
 
 
Joined: 06 Jul 2007

Re: SLADE3 beta (testing release, beta5 up)

Postby sirjuddington » Thu Jun 10, 2010 9:33 pm

jdtm wrote:Of course i read the README-unix. How else would i know that it needed wxwidget and freeimage. According to the readme, WxWidgets needs to be version 2.9+, and when i went to the website to get it (because 2.9+ wasnt in synaptic) and so far their latest version is the 2.90 development snapshot. i downloaded it and went to build it, and it gave me all the mumbo-jumbo from above.
I'll admit that I'm not as good with Linux as other people.

To compile wxwidgets you need the gtk dev packages (don't remember the names exactly, something like libgtk2-dev, just search for it). Forgot about the 2.9 thing (wish they would hurry up with the next stable wxwidgets version, 2.8 is old as the hills now) - wxwidgets and slade are the only 2 things you have to compile, the rest of the dependencies for both are in the package manager.
User avatar
sirjuddington
 
Joined: 16 Jul 2003
Location: Australia
Discord: sirjuddington#7496
Github ID: sirjuddington

Re: SLADE3 beta (testing release, beta5 up)

Postby Gez » Sat Jun 12, 2010 5:52 am

SVN builds will from now on be available here: http://svn.drdteam.org/slade/
Gez
 
 
 
Joined: 06 Jul 2007

Re: SLADE3 beta (testing release, beta5 up)

Postby NeuralStunner » Sat Jun 12, 2010 12:26 pm

Good news. =:)

Found a few issues worth noting (Beta 5):

- When opening a .wad file (via a custom set association), I get "Windows cannot find 'D:\Path\Goes\Here\Some.wad'. Make sure you typed the name correctly, and then try again." The file then loads correctly. This does not happen with PK3 and other archive formats. The "command line" used is precisely the same for each.
- I got this random crash while viewing PNGs in ZDoom.pk3. (I got one before while looking through PNGs, but I'm not sure what the numbers were.)
Slade Crash Box wrote:Stack Trace:
0: ()
1: ()
Yeah, helpful...
Windows Dialog wrote:The Instruction at 0x5ed0530e" referenced memory at "0x0000051c". The memory could not be "read".
It didn't do this the second time I opened it and viewed the same graphic.

A few things I'd like to see still:
- When multiple files are opened from Explorer, open them in the same instance of Slade.
- The ability to drag and drop files into Slade to open them.
- "All files (*.*)" option in the Open dialog, perhaps .pk7 and .pkz extensions in the list, too. :)
User avatar
NeuralStunner
An Exercise in Self-Indulgence
 
 
 
Joined: 21 Jul 2009
Location: Indiana, USA
Discord: NeuralStunner#1293
Operating System: Windows Vista/7 64-bit

Re: SLADE3 beta (testing release, beta5 up)

Postby Gez » Sat Jun 12, 2010 12:43 pm

NeuralStunner wrote:Good news. =:)

Found a few issues worth noting (Beta 5):

By that you don't mean r540, do you? If you haven't tried r540, please try it and tell me if the problem is still there.

The stack trace only works if you have the corresponding PDB file in the same directory as the exe and pk3, by the way.
Gez
 
 
 
Joined: 06 Jul 2007

PreviousNext

Return to Editors / Asset Manipulation

Who is online

Users browsing this forum: No registered users and 1 guest