4.8 causes white screen when launched from UDB

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

4.8 causes white screen when launched from UDB

Postby peewee_RotA » Thu Jun 23, 2022 8:01 am

I updated to 4.8 for compatibility with Hands of Necromancy. Ever since upgrading, launching a test from Ultimate Doom Builder causes a white screen to appear. When I press ~ or Esc, the white screen goes away and the game functions normally.

The only other thing I could find was that iwad selection is off by default now. I know that there can be weird results when the wrong IWAD is loaded. So I turned the selection back on, and loaded the game normally to see if I could reproduce, but no dice.

Here's the resulting command line that the map editor launches:
Code: Select allExpand view
-iwad "C:\Games\hexen\base\HEXEN.WAD" -skill "3" -file "C:\Games\packs\xrpglevels" "C:\Games\packs\xrpglevels\xrpglevels.wad" "C:\Users\user\AppData\Local\Temp\4l080n3n\fxnvaf75.wad" +map MAP16  -file "C:\Games\xrpg\pk3\v1_4_1\xrpg.pk3" +playerclass "Random"


OS: Windows 10

Will follow up with a video.
peewee_RotA
 
Joined: 07 Feb 2014

Re: 4.8 causes white screen when launched from UDB

Postby peewee_RotA » Thu Jun 23, 2022 8:17 am

Video comparing 4.6.1 to 4.8
https://youtu.be/QxsJEeW7Nwc
peewee_RotA
 
Joined: 07 Feb 2014

Re: 4.8 causes white screen when launched from UDB

Postby Blue Shadow » Mon Jun 27, 2022 11:58 pm

I got this problem today (I'm assuming it's the same) with GZDoom 4.8.1 and OpenGL as the backend. Here is how it can be reproduced:

  • Start GZDoom from the command-line with the attached file, and Heretic as the game, while warping to E1M1. You shouldn't notice anything strange. Everything is fine.
  • Quit GZDoom, then start it again (from the command-line just like before), only this time warp to E1M2. The result is that you get a black/white screen.

Things to note:

  • The difference between the two maps is that in E1M2, in which the glitch happens, the player is facing away from the sky. Once the player turns around, and the sky comes into view, the glitch disappears.
  • You need to run a game that has a startup screen, like Heretic, Hexen and Strife. If you try the steps above with Doom (no startup screen), you won't get the glitch.
You do not have the required permissions to view the files attached to this post.
User avatar
Blue Shadow
 
Joined: 14 Nov 2010
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD (Modern GZDoom)


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests