GZDooM seems to be randomly crashing

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

GZDooM seems to be randomly crashing

Postby Okgo5555 » Sat Dec 04, 2021 11:35 am

Hello,

I am working on somethings in Slade 3.1.3 and I seem to be getting this random crash as I iterate on the project I am working on.

When I test the .wad, it will seem to load and run fine without at hitch. I've even gone so far as to go through the debug report and reconcile all of GZDooM's complaints about my work (I have a bad habit of using the syntax "none" or 0 when the argument should be none). So, things will move along swimmingly and then, on the next iteration, GZDOOM will hard crash to a crash report dialogue. It will say that I cannot read an address.

Screenshot below: (yes, I named the PNG "error.png")

https://www.mediafire.com/file/9gxn5wv9clfe992/error.png/file

The strange part is that this does not happen every time. Often, If I close out the .wad in SLADE, reopen it, and then run a new test, GZDOOM will launch the project without a hitch. Furthermore, when GZDooM doesn't tank, there doesn't seem to be any issues during the GZDOOM start up where most crash errors are usually debugged. The only information I have in the crash reports is the screenshot I provided and I can see that GZDooM gets to "LoadActors: Load actor definitions." when the crash does occur. Also, this error and crash report shows up the same every time. the difficulty is that it does not happen every time. Sometimes I may need to restart Windows, sometimes I have to close out everything and go back to where I was, sometimes just re-opening the file will do the trick. The only other piece of information I can discern here is that once the crash DOES happen once, GZDooM will not run the file again until I change the circumstances (like loading the .wad over again in Slade or using the command prompt or just restarting my computer.).
Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555

Re: GZDooM seems to be randomly crashing

Postby Okgo5555 » Sat Dec 04, 2021 8:27 pm

Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555

Re: GZDooM seems to be randomly crashing

Postby Kappes Buur » Mon Dec 06, 2021 8:07 pm

Your are trying to load 2 extra mods

    Wad 0: gzdoom.pk3
    Wad 1: zd_extra.pk3
    Wad 2: DOOM.WAD
    Wad 3: PyWeaponWheel_v0.3.pk3
    Wad 4: newweapons.wad

PyWeaponWheel_v0.3.pk3 works without problems, at least for me. I tried it with several other mods, like Hellforged, etc.

What is this newweapons.wad? I could not find it. My guess is that it is this pwad which causes the problem. Can you provide more info about it, or better still since you have it, upload it for perusal.

Which version of GZDoom?
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada

Re: GZDooM seems to be randomly crashing

Postby Okgo5555 » Sat Dec 11, 2021 9:38 pm

I will upload the was when I get up tomorrow. It is a personal mod of mine that I am working on. It's WIP. I'm on EST. I get your answers soon. Thank you so much for the reply.
Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555

Re: GZDooM seems to be randomly crashing

Postby Okgo5555 » Thu Dec 23, 2021 3:46 pm

Here is my WIP personal mod called "newweapons.wad"

https://www.mediafire.com/file/t60l9opi1vosm04/newweapons.wad/file
Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555

Re: GZDooM seems to be randomly crashing

Postby Kappes Buur » Wed Dec 29, 2021 3:53 pm

This is odd, sometimes, using both addons, it will work and sometimes it will crash, like this


regardless of load order

and when it does work the wheel looks like this with all weapons given



So, somewhere there is some overlapping clash between the addons
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada

Re: GZDooM seems to be randomly crashing

Postby Okgo5555 » Mon Jan 03, 2022 1:06 pm

Hmm.. thanks. When it crashes on my, I DO NOT get that "DemonNew" Error. That is a replacement for the pinky demon. There must be some syntax that I have missed. The weird part is that my debug readout is different. Thanks for the help So far!
Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555

Re: GZDooM seems to be randomly crashing

Postby Okgo5555 » Mon Jan 03, 2022 1:28 pm

I cut out the coding for "DemonNew" and it seems to be running reliably. That must be the root of the issue. I will have to go through and more carefully implement what I was going for. Shame on me because I hadn't reall got to work on the Imp variations yet anyway.
Okgo5555
 
Joined: 23 Mar 2017
Discord: Okgo5555


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests