JIT: passing vector2/3 by reference causes error/crash.

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

JIT: passing vector2/3 by reference causes error/crash.

Postby Accensus » Fri Oct 15, 2021 4:33 am

Tested on GZDoom 4.7.0. I say error/crash because I am reporting this on behalf of my friend who gets the crash ...but only sometimes. Meanwhile I only get an error.

Error:
Code: Select allExpand view
TestImp.PostBeginPlay: Unexpected JIT error: Unknown REGT value passed to EmitPARAM


To reproduce using the attached example, use "summon TestImp".
You do not have the required permissions to view the files attached to this post.
Accensus
 
Joined: 11 Feb 2016

Re: JIT: passing vector2/3 by reference causes error/crash.

Postby phantombeta » Fri Oct 15, 2021 8:13 am

Probably a duplicate of this bug
User avatar
phantombeta
Tired of being treated like trash by control freaks
 
Joined: 02 May 2013

Re: JIT: passing vector2/3 by reference causes error/crash.

Postby Accensus » Fri Oct 15, 2021 8:36 am

Looks like it. It works under specific circumstances, e.g. this. Code's been like that for a while and I have yet to see any issues.
Accensus
 
Joined: 11 Feb 2016


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest