[Fixed] [4.7.0] regression in DEHEXTRA support?

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

[4.7.0] regression in DEHEXTRA support?

Postby Delfino Furioso » Thu Sep 23, 2021 7:20 am

Hi, I have had this wad in my autoload section for quite some time now

Since deploying gzdoom 4.7.0 I've started noticing that the rocket launcher blast radius is bigger than usual:
  • the player is taking damage despite being well over the expected safe distance
  • in a large room (such as kinsie's test map) explosion decals spreads across almost all walls

I've tested this in a clean 4.7.0 setup without loading any other mod.
I'm not facing such issues when using 4.6.1.

I'm lacking the knowledge to correctly determine if this is a bug with gzdoom or the wad coding itself.
I however thought that this was worth mentioning here.

Thank you for investigating on this!
User avatar
Delfino Furioso
 
Joined: 27 Mar 2021

Re: [4.7.0] regression in DEHEXTRA support?

Postby Wally0222 » Sat Sep 25, 2021 12:24 am

Not sure if I encountered a similar bug like you reported, so I upload 2 simple demo PK3s which uses DECORATE to replaces DoomPlayer with a Chaingun (1demo.pk3) or Plasma Rifle (2demo_replace.pk3, as an addon).

I tried both autoload and ZDL to load these 2 PK3s , the "2demo_replace.pk3" still won't work in 4.7.0 and newer dev builds (works in 4.6.1 and Zandronum though), looks like it just loaded "1demo.pk3" without "2demo_replace.pk3"...
User avatar
Wally0222
 
Joined: 28 Apr 2021
Location: Pantai Remis, Perak, Malaysia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)

Re: [4.7.0] regression in DEHEXTRA support?

Postby Graf Zahl » Sun Oct 03, 2021 10:27 am

Fixed the original bug.

@Wally0222: Please do not post totally unrelated reports in other threads.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [4.7.0] regression in DEHEXTRA support?

Postby Delfino Furioso » Sun Oct 03, 2021 10:43 am

nice!

thank you Graf
User avatar
Delfino Furioso
 
Joined: 27 Mar 2021

Re: [4.7.0] regression in DEHEXTRA support?

Postby Wally0222 » Sun Oct 03, 2021 11:19 am

Graf Zahl wrote:@Wally0222: Please do not post totally unrelated reports in other threads.

That because I said "not sure" at the beginning, I should have to report the bug in the new topic/thread earlier (or not)...
Pardon my ignorance, I kinda have a bad mood when I about to post the totally unrelated reports... :cry:
User avatar
Wally0222
 
Joined: 28 Apr 2021
Location: Pantai Remis, Perak, Malaysia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 2 guests