SNDSEQ: play/playuntildone issues

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

SNDSEQ: play/playuntildone issues

Postby Jekyll Grim Payne » Fri Jul 09, 2021 6:20 am

This is a continuation of my struggle described here.

First of all, play and playuntildone seem to function completely identically. That seems like a bug to me.

Second, I decided to implement a fix for the issue described above physically into my sounds. Now the "start" sound includes both a start and a single loop sound playing over each other, then the "playrepeat" sound is just the looped sound alone. The idea is that the starting sound will play first, then the looped sound follows without any delays.

However, for some unknown reason in some sound definitions there's a tiny but very noticeable delay between the "play" and the "playrepeat" sounds.
You do not have the required permissions to view the files attached to this post.
User avatar
Jekyll Grim Payne
 
Joined: 21 Jul 2008
Discord: Agent_Ash#4401
Github ID: jekyllgrim
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia (Modern GZDoom)

Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests