[Not a bug] Rotating PolyObj doesn't always hit the player

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Rotating PolyObj doesn't always hit the player

Postby SPZ1 » Tue Mar 09, 2021 3:33 pm

The idea here is that the rotating PolyObject should always strike and kill the player but most of the time this does not happen! Most spots you can stand around in and not get hit. If you run around it is easier to get hit though. :?
You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: Rotating PolyObj doesn't always hit the player

Postby SPZ1 » Sun May 02, 2021 5:13 am

I just checked a different PolyObj style that doesn't rely on single lines but the problem is still here. :( . Check the new attached PolyObj_RotateAndHit2.7z

Also, sorry for the double post
You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: Rotating PolyObj doesn't always hit the player

Postby Graf Zahl » Wed May 19, 2021 8:50 am

This setup cannot work.
A line trigger is activated when an actor crosses the line, not when the line crosses the actor.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Rotating PolyObj doesn't always hit the player

Postby SPZ1 » Thu May 20, 2021 5:08 pm

Well at least I know why it isn't working now :(
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests