Sound sequence cant be heared but still take channel [4.4.2]

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Sound sequence cant be heared but still take channel [4.4.2]

Postby Apeirogon » Tue Oct 27, 2020 12:18 pm

Sound sequence attached to sector with script takes sound channel even if camera that can hear this sound is way to far away from sector with this sound sequence.

Load file and start new game. Right at the start you should hear "pistol shot" sound sequence attached to sector. Open console and type "stat sound". It would show that one channel currently busy by this "pistol shot" sequence. Now type in console "warp 30000 0 0" for example, or any other big numbers. After warping sound statistics will still shows that one channel currently still "play" something. It dosent looks right.
sec_seq_chan_bug.zip


Cant say is it a my error or engine bug, since sound sequence related functions dont documented well.
You do not have the required permissions to view the files attached to this post.
User avatar
Apeirogon
I have a strange sense of humour
 
Joined: 12 Jun 2017

Return to Bugs

Who is online

Users browsing this forum: No registered users and 3 guests