Dynamic lights sometimes don't move along with objects

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Dynamic lights sometimes don't move along with objects

Postby Player701 » Thu Oct 15, 2020 2:29 am

Dynamic lights sometimes don't move along with objects

It seems that in certain cases dynamic lights attached to objects (e.g. decorations) will not move with them when the floor those objects are placed on is raised or lowered.

I couldn't reproduce this in an isolated test map, but here's a map where this can be reproduced reliably: EPIC MAP02. Use the following command-line parameters (and make sure to autoload lights.pk3):

Code: Select allExpand view
gzdoom -file epic.wad -iwad doom2 -warp 2 -nomonsters +"warp -4064 -5504"


Then do the following:

  1. Press the switch on your left side. The elevator to your right will come up. There are two candles on it. (These ones do not manifest buggy behavior)
  2. Now step onto the elevator. You will be silently teleported to another area of the map. There are also two candles here, but they don't seem to have any dynamic lights. This is not expected behavior.
  3. Press the switch in front of you to lower the elevator. Now that it's come down, the candles seem to have dynamic lights again.

Tested in GZDoom 4.3.1, 4.4.2, and g4.5pre-256-gaa16fefd8
User avatar
Player701
 
Joined: 13 May 2009
Location: Russia
Discord: Player701#8214
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest