[Fixed] Additive 3D Floors Affecting Fog Below Them

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Additive 3D Floors Affecting Fog Below Them

Postby Kinsie » Tue Jun 02, 2020 10:55 pm

Image

As you can see, the linedefs below the additive 3D floors are not affected by fog settings, even when they should be. Not sure if this is something we're doing wrong, or a renderer bug, but the issue is not present in the ancient version of the OpenGL renderer used in Zandronum 3.0. (We're trying to narrow down the version things changed, we'll keep you posted)
Attachments
fogbug.wad
(45.14 KiB) Downloaded 3 times
User avatar
Kinsie
Dog Days
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie

Re: Additive 3D Floors Affecting Fog Below Them

Postby TheShadsy » Tue Jun 02, 2020 11:15 pm

This also appears to be unaffected by any of the Sector_Set3DFloor flags for disabling or resetting lighting effects.

The issue seems to have originated in GZDoom 2.1.0. See comparison shots below of the sample wad in 2.0.05 vs. 2.1.0.
Attachments
GZDoom 2.1.0 rendering issue.png
TheShadsy
 
Joined: 15 Apr 2012

Re: Additive 3D Floors Affecting Fog Below Them

Postby Graf Zahl » Wed Jun 03, 2020 1:35 pm

fixed. Amazing that it took this long to find such a relatively obvious bug.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Additive 3D Floors Affecting Fog Below Them

Postby Kinsie » Thu Jun 04, 2020 8:16 am

Thanks for the quick fix on this!
User avatar
Kinsie
Dog Days
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie


Return to Closed Bugs

Who is online

Users browsing this forum: Semrush [Bot] and 1 guest