Resurrected monster is not friendly (gzdoom-x64-g4.4pre-39-)

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Resurrected monster is not friendly (gzdoom-x64-g4.4pre-39-)

Postby yura_111 » Fri May 01, 2020 10:59 am

If I resurrect a dead monster, then in some cases it is not friendly. This happens in conjunction with the use of “A_Die” and “RandomSpawner" and possibly something else.

(Actor "DoomedSpaceMarineGreen3" for resurrect)
Example:
Attachments
new 1.txt
(4.22 KiB) Downloaded 7 times
yura_111
 
Joined: 12 Oct 2019
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Resurrected monster is not friendly (gzdoom-x64-g4.4pre-

Postby Rachael » Fri May 01, 2020 4:09 pm

Just to ensure there is no confusion - what is the behavior you are expecting here?

Remember that the resurrected monster takes on the +FRIENDLY status of the archvile/creature that resurrects it - not its original +FRIENDLY state.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Resurrected monster is not friendly (gzdoom-x64-g4.4pre-

Postby Ursula Bennerville » Sat May 02, 2020 1:25 am

In a normal situation, a resurrected monster becomes friendly (if a player resurrect it). But in this situation, the resurrected monster is not friendly until you kill it and again resurrect. Even the forced setting of the flag "Friendly" through the function "A_ChangeFlag" does not give a result.

For Example:
Summon "DeadMarineSpawnPoint" and try resurrect it
Ursula Bennerville
 


Return to Bugs

Who is online

Users browsing this forum: JPL and 2 guests