bad macro message

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

bad macro message

Postby drfrag » Mon Feb 24, 2020 8:56 am

Latest master. I get the "Bad macro in el : TXT_BY" error message in the console with Doom shareware all games.
Last edited by drfrag on Mon Feb 24, 2020 9:30 am, edited 1 time in total.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Github ID: drfrag666

Re: bad macro message with doom1.wad

Postby Rachael » Mon Feb 24, 2020 9:10 am

I get that on the Raspberry Pi on Linux no matter what game I use. In this case, it was Chex Quest 3.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: bad macro message

Postby drfrag » Mon Feb 24, 2020 9:32 am

And on windows, i've just noticed it happens with all games and i suspect this commit https://github.com/coelckers/gzdoom/com ... 34addf6f97
What is 'el'?
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Github ID: drfrag666

Re: bad macro message

Postby Graf Zahl » Mon Feb 24, 2020 10:30 am

Greek
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: bad macro message

Postby drfrag » Mon Feb 24, 2020 12:55 pm

I thought that could be a typo.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Github ID: drfrag666

Re: bad macro message

Postby Graf Zahl » Fri Feb 28, 2020 3:25 am

Updating the engine text file should fix it, I corrected this thing very shortly after the last text update.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests