Page 1 of 1

[Strife] Some com unit messages don't show subtitles

PostPosted: Thu Jul 11, 2019 12:34 pm
by Xeotroid
Communicator messages that are only logged as "Incoming message..." don't trigger subtitles, examples being the first and third messages from Blackbird ("Listen, this com unit tells me that you're 100% human..." and "Go through the door on your left..."), even though they are printed into console. Messages that are logged as "Incoming message from Blackbird..." do work (although they never disappear until another one comes through, but that's already reported).
Image

(Edit: Added example image and removed the irrelevant question)
EDIT: Correction: The console output are different logs, the ones that can be accessed in the mission objectives pop-up screen, not subtitles. They were basically identical, sorry, my bad. The main issue still stands.

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Mon Jul 15, 2019 3:37 pm
by drfrag
How can i test subtitles in a quick and easy way? Where's that Blackbird guy?

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Mon Jul 15, 2019 4:56 pm
by Xeotroid
Check the map I posted in the attachment. It emulates getting the communicator and QuestItem1 from Rowan and then walking over the first two voice triggers (the steps in the map). It's on MAP02, so you can start there in Strife right away. It also made me notice a bug where the subtitle box doesn't disappear when starting a new game while the box is still visible. Two birds with one stone, I guess.

I'm guessing that the first line, using special 202, only plays a sound and puts some text into the mission objectives while the subtitles are only for special 215. No idea how that translates to the current localisation efforts.

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Mon Jul 15, 2019 5:00 pm
by Graf Zahl
I'll have a look after finishing the localization setup for Harmony, which may take 2 or 3 more days.

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Tue Jul 16, 2019 6:52 am
by drfrag
It's just a missing TXT_SUB_LOG2 string, fixed that one in the vintage build. I'm copy-pasting all those strings now, hope this feature is not only useful for Strife.
Edit: and TXT_SUB_LOG4. Should all the logs have subtitles? I haven't played Strife.

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Tue Jul 16, 2019 8:21 am
by Graf Zahl
Those are the ones identical with the actual logs. I think I forgot to add that special check for the fallback for them.

Re: [Strife] Some com unit messages don't show subtitles

PostPosted: Wed Jul 17, 2019 1:03 pm
by Graf Zahl
These are in now.