Inconsistent font rendering in menu

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Inconsistent font rendering in menu

Postby VoidMage » Thu Apr 18, 2019 7:00 am

As of 35186e9fd722.
This looks a bit like the problem here, but this time affecting the standard menu.

menu_sshot.png


As you may see, some of the glyphs on some of the lines are clipped.
There might be a pattern to it, but it must be a quirky one - it doesn't depend on the glyphs, as they're rendered correctly in other places of the same menu, neither does it seem to depend on glyph color.
User avatar
VoidMage
 
Joined: 02 Dec 2010

Re: Inconsistent font rendering in menu

Postby Graf Zahl » Thu Apr 18, 2019 7:19 am

What screen resolution, scale factor and scaling mode are you using?
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Inconsistent font rendering in menu

Postby VoidMage » Sun Apr 21, 2019 6:38 am

I doubt resolution matters - it happens both widowed and fullscreen.
It seems to be set to 800x600 though.

I use either hqnx or xbrz - problem visible with both.
User interface scale set to 2.

If you were referring to something else, say so clearly.
User avatar
VoidMage
 
Joined: 02 Dec 2010

Re: Inconsistent font rendering in menu

Postby Undead » Tue Apr 23, 2019 4:27 am

Graf is referring to your GZDoom resolution (regardless of whether it is windowed or fullscreen), the “Resolution scale” and “Scale factor” settings in GZDoom, all found in Options > “Set video mode”.
User avatar
Undead
 
 
 
Joined: 26 Dec 2013
Location: Sweden

Re: Inconsistent font rendering in menu

Postby Graf Zahl » Tue Apr 23, 2019 4:55 am

Was this really 800 x 600?
There was a problem causing a glitch like this when the window was dragged to its minimum size. The handler allowed a minimum WINDOW size of 640 instead of a minimum CLIENT size and if that happened the problem described here happened - it was also the only case where I could reproduce it, and that part is already fixed.

If this is Linux, though, I cannot say. If this is the case there may be a problem in the backend code reporting wrong window sizes.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Inconsistent font rendering in menu

Postby Rachael » Tue Apr 23, 2019 5:54 am

There is currently an issue in Windows where the client size can be arbitrarily set (vid_setsize) to a small size - however the scaling code handles this by forcing the scaling to be 640x400 minimum no matter what the window size is.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Inconsistent font rendering in menu

Postby Graf Zahl » Tue Apr 23, 2019 6:18 am

I fixed that issue yesterday. The limit was 640x400 window size, not 640x400 client size.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Inconsistent font rendering in menu

Postby VoidMage » Sun Apr 28, 2019 9:33 am

Let's put it this way:
Code: Select allExpand view
vid_aspect=0
vid_vsync=false
vid_defheight=600
vid_defwidth=800
vid_rendermode=4
win_h=819
win_w=1024
win_y=102
win_x=128


...and yes, it's Linux.

Also, for comparison (as of 6d1a85af3c5a5f6):

menu_sshot2.png


...so it seems distortions happen at a certain height...
User avatar
VoidMage
 
Joined: 02 Dec 2010


Return to Bugs

Who is online

Users browsing this forum: Awario [RSS] and 1 guest