Models with "####" Don't Interpolate

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Models with "####" Don't Interpolate

Postby Doris Geddlewodging » Fri Feb 08, 2019 12:45 pm

From the fix introduced in this thread:
viewtopic.php?f=7&t=63525

Models applied to frames using "####" will now appear, however they do not seem to honor interpolation.

http://edthebat.com/doom/interptest.pk3
In this example, Zombieman2 is created to mimic Zombieman. Models are applied to both.
Only difference is that Zombieman2 uses "####" for its sprite names. Examine both actors in-game and compare.
Doris Geddlewodging
 

Re: Models with "####" Don't Interpolate

Postby Graf Zahl » Fri Feb 08, 2019 1:02 pm

Yes, this is a known problem - unfortunately one that isn't easy to fix because that "####" makes it problematic to retroactively retrieve the needed info to perform an interpolation.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest