32bit version end screen

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

32bit version end screen

Postby Emma Bommerdatch » Mon Dec 17, 2018 2:13 am

In 32bit Windows version, the level end screen statistics (Items, Secrets etc) do not display. I hear the sound of numbers updating, but there is no numbers. It's not a big deal, because the minimap stats during the level work fine, but it's still silly.
Also I checked, and this still persists in the latest development version. Also, I tried cleaning the .ini file and it didn't change anything. It persists consistently - mods, vanilla - in every game with an endscreen - Doom 1, Doom 2, Final Doom, Heretic, Harmony or Hacx. In fact, it looks like the end screen straight up refuses to update image after the first frame - if you open menu or console during endscreen, there will be no visible change on-screen.

I'm using 32-bit Windows 7.
Emma Bommerdatch
 

Re: 32bit version end screen

Postby Graf Zahl » Mon Dec 17, 2018 2:31 am

You seem to be very alone with this issue.What's your hardware, and what video/render configuration do yiou use?
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: 32bit version end screen

Postby shino1 » Mon Dec 17, 2018 6:06 am

My hardware is:
CPU: Intel Core 2 Duo P8600, 2.4 GHz
RAM: 2 GB
GPU: Ati Mobility Radeon 3650 HD
System: Windows 7 Ultimate 32-bit
Like I said, I'm using the 32 bit version.
I have no idea what is my sound hardware, as I can't even see a real name in Device Manager.

I was using Open GL accelerated... but while testing that I found even more stuff! Further discoveries: turns out that when I'm using any other render (Software, Truecolor, Softpoly, Truecolor Softpoly) exact same issue happens *during regular gameplay* - the game stops updating after the first frame, and I can't see anything. I had to exit the game blindly because I couldn't see the menus. Main menu works fine. I should note that before, Software Renderer always worked fine on this configuration. Also, everything happens identically in windowed and fullscreen.

This did not occur in last version I used, GZDoom 3.25 - and in fact, nothing like that ever occurred on this computer, and I've been playing GZDoom a lot on it for the last year. Software Renderer also always worked fine, even if I used it rarely.

Okay, even MORE crazy discoveries - Software Renderer works perfectly fine *if* I switch to it *during* the gameplay, so long as I start playing in Open GL. But if I start a new level with it (e.g. exit the level and start the next one), then it stops updating again. In fact, it actually stays on the first frame of the end screen graphic, and doesn't even update for the first frame of a new level. I can't tell if the game would 'fix itself' if I started in software and then switched to OpenGL during gameplay - as I can't see the menus, and it's impossible to switch renderers blindly.

It should be noted that the game clearly plays 'normally' underneath all that - I can move, shoot, and even hit enemies (judging by their screams), it's just that graphics don't update.

EDIT: I always update my GZDoom by overwriting my old folder, and the folder itself is actually a year old. So just in case, I made a clean install of GZDoom in a new folder, and nope! The same issue happens.
Last edited by shino1 on Mon Dec 17, 2018 6:54 am, edited 1 time in total.
shino1
 
Joined: 17 Dec 2018
Discord: shino1#6558

Re: 32bit version end screen

Postby shino1 » Mon Dec 17, 2018 6:42 am

Also since you ask for, here's a quick recording of both issues (end screen in OpenGL, and software renderer) in OBS. The ridiculous chugging during the OpenGL level is not a glitch, it's just my computer is crap and can't really handle Chrome, OBS and GZDoom being open at the same time. However, the end screen/software renderer thing is obviously not just a performance issue.
https://drive.google.com/open?id=14m-vy4_1eSgth55qVtUkGec3GG5vUPNc
shino1
 
Joined: 17 Dec 2018
Discord: shino1#6558

Re: 32bit version end screen

Postby drfrag » Mon Dec 17, 2018 6:48 am

Those are known problems, you have a very old graphics card and those GL 3.3 ATI cards had very buggy drivers. Before there were workarounds to make them work but they were recently removed while doing an engine clean up as part of the preparation for Vulkan.
You need to use the vintage build instead. Then if you're still experiencing problems please report back.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: 32bit version end screen

Postby shino1 » Mon Dec 17, 2018 6:58 am

Thanks, vintage build seems to have fixed everything! Thank you for your help!
shino1
 
Joined: 17 Dec 2018
Discord: shino1#6558


Return to Bugs

Who is online

Users browsing this forum: Zhs2 and 3 guests