[Fixed] [4.3.3] Powerups no longer play sounds

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

[4.3.3] Powerups no longer play sounds

Postby SanyaWaffles » Thu Jan 23, 2020 11:05 pm

When using the ActiveSound for PowerDamage, or the various sounds for PowerProtection, I no longer hear the sounds being emitted when the player gets hit (in the case of PowerProtection) or whenever your are attacking (with PowerDamage). They worked before... I think this is a regression related to the A_StartSound and related stuff as I know it worked before.

I can confirm that the sounds are defined properly.

Minimal example: https://www.dropbox.com/s/4cqqutwbqzdpm ... g.pk3?dl=1

summon OrbOfProtection and summon QuadDamage and see that none of the sounds are playing as they should be.

Oddly my DoEffect sounds work fine with A_StartSound. I have no idea why they aren't working otherwise though.

EDIT: I think I found the problem. A_StartSound instances in the Powerups department didn't get their flags updated:

Code: Select allExpand view
if (Owner != null && newdamage < damage) Owner.A_StartSound(ActiveSound, CHAN_AUTO, 1.0, false, ATTN_NONE);


should be

Code: Select allExpand view
if (Owner != null && newdamage < damage) Owner.A_StartSound(ActiveSound, CHAN_AUTO, CHANF_DEFAULT, 1.0, ATTN_NONE);


EDIT 2: I can confirm this is indeed the problem after fixing the ZScript on my project's side. Several A_StartSound calls are omitting the flags parameter.
Last edited by SanyaWaffles on Fri Jan 24, 2020 6:30 pm, edited 1 time in total.
User avatar
SanyaWaffles
Navy Did Nothing Wrong
 
Joined: 25 Apr 2013
Location: Eastern Ohio
Discord: SanyaWaffles#5095
Twitch ID: sanyawaffles
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: [4.3.3] Powerups no longer play sounds

Postby _mental_ » Fri Jan 24, 2020 3:58 am

Fixed in 081cf81.
_mental_
 
 
 
Joined: 07 Aug 2011


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests