Doom RPG SE [unofficial, bugfix-ish]

For Total Conversions and projects that don't otherwise fall under the other categories.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby affandede » Tue Mar 19, 2019 5:18 am

Sumwunn wrote:Hmm, only event that causes FPS drops for me is Vicious Downpour (I have a Intel HD 515). You must have a pretty old PC?
Is there anything in particular that causes the drops?


I have a laptop with an i5, 8 gigs of ram and a GT940m graphics card. The lag is probably caused by some obscure GZDoom setting(s?). By the way, I am playing drpg with drla. Maybe faster attacking monsters and all those effects do something? I've also noticed some intense lag even without an event on some later maps of Scythe 2.
User avatar
affandede
 
Joined: 11 Nov 2017

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby OfficialYeen » Thu Mar 21, 2019 1:48 am

Bug report:
Shield parts don't show up in your inventory when you buy them, thus using a shield is impossible. Running this via ZDL with RLA 1.1, but I encountered the same problem when running DoomRPG only. Everything else seems to be fine, but I haven't played for very long, so I probably haven't had the chance to encounter any more bugs.

Also, you are doing God's work by keeping DRPG alive. Cheers, friend. :D

EDIT:
I got the same problem launching DRPG and DRPG + RLA 1.1 via the DRPG launcher, so it doesn't seem to be a load order problem.
User avatar
OfficialYeen
 
Joined: 12 Feb 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby affandede » Thu Mar 21, 2019 8:51 am

Because shield parts are not supposed to be shown in your inventory. Check the Shield page on Drpg menu.
User avatar
affandede
 
Joined: 11 Nov 2017

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby OfficialYeen » Thu Mar 21, 2019 9:16 am

Ah, poor working on my part. I did check the shield page.
User avatar
OfficialYeen
 
Joined: 12 Feb 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby Sumwunn » Thu Mar 21, 2019 11:52 am

OfficialYeen wrote:Ah, poor working on my part. I did check the shield page.


Haha that's rough! Just another day with DRPG.

What shield part(s) did you buy?

It's not on the desk in the shop right?
User avatar
Sumwunn
Runaway script "_Sumwunn" terminated
 
Joined: 06 Jan 2018
Location: Snited Utates
Discord: Sumwunn#9562

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby Forevener » Thu Mar 21, 2019 12:49 pm

DRPG SE Launcher v1.0 is released, please update.
Forevener
 
Joined: 20 Sep 2015
Location: Ufa
Discord: Forevener#3317

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby OfficialYeen » Thu Mar 21, 2019 3:49 pm

Sumwunn wrote:
OfficialYeen wrote:Ah, poor working on my part. I did check the shield page.

It's not on the desk in the shop right?

omfg... it was indeed on the desk in the shop because I had "shop anywhere" toggled off. Thanks for helping me figure this out! It seems so obvious now. :lol:
User avatar
OfficialYeen
 
Joined: 12 Feb 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby YukesVonFaust » Wed Mar 27, 2019 5:27 am

Thanks for making Doom RPG stay alive. although there's only one roadblock...

Why the "Runaway Script "_MonsterStatsInit" terminated" spews out sometimes after i play it for sometime (usually maps 10 to 19)? it's a gamebreaking bug.

has anyone encountered this runaway script thingy before?
User avatar
YukesVonFaust
Kicking Asses and Taking Names
 
Joined: 09 Feb 2015
Location: in your area, where else
Discord: Yukes von Faust#9009
Operating System: Windows Vista/7 64-bit

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby OfficialYeen » Thu Mar 28, 2019 2:41 pm

YukesVonFaust wrote:Thanks for making Doom RPG stay alive. although there's only one roadblock...

Why the "Runaway Script "_MonsterStatsInit" terminated" spews out sometimes after i play it for sometime (usually maps 10 to 19)? it's a gamebreaking bug.

has anyone encountered this runaway script thingy before?

I've been getting "runaway script "_MonsterDeath" terminated" frequently, but it doesn't seem to affect anything, so I just put it on the list of DRPG quirks.
User avatar
OfficialYeen
 
Joined: 12 Feb 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby Sumwunn » Thu Mar 28, 2019 7:59 pm

Sigh, those are the bane of DRPG.
I haven't seen those in ages. I hoped they got fixed along with compiler updates. The fact that it's still happening means I shall have to sift through the depths of the monster code.

I'm sorry guys. Must be really annoying to see a "bugfixed version" only to have it crash same old.

I'll give this high priority.

Also, is it just a few scripts or the whole mod?

EDIT:
Hey guys, I've made some changes to how the monster handlers are handled when they are dead/alive. This solved the following scripts from running away after killing all monsters then teleporting into the Outpost from NUTS.WAD. I'm not sure how that translates into a normal play-through but it makes some sense if play-throughs are crashing midway through WADS. Something to do with total monsters killed it seems.
- MonsterInit, MonsterInitStats, MonsterStatsHandler, MonsterAuraDisplayHandler, MonsterRegenerationHandler & MonsterAggressionHandler.
I have the fixes uploaded to my experimental branch. If someones willing to do another play-through with the potentially crashing. I'd be so grateful.
https://github.com/Sumwunn/DoomRPG/tree/experimental

Experimental also reworks how shield damage is handled (zscript, yay!). That rework also fixes some DRLA armour getting stuck after activating shield. Details are in the commit itself.
User avatar
Sumwunn
Runaway script "_Sumwunn" terminated
 
Joined: 06 Jan 2018
Location: Snited Utates
Discord: Sumwunn#9562

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby OfficialYeen » Fri Mar 29, 2019 4:24 pm

Sumwunn wrote:I'm not sure how that translates into a normal play-through but it makes some sense if play-throughs are crashing midway through WADS. Something to do with total monsters killed it seems.

Oh, I didn't know that was a DRPG thing. I've been experiencing crashes after playing for a while (I play this using Sentinel's Lexicon), but I just assumed it was my bad laptop being bad since it crashes all the time when I try to play fancier mods. Cheers, I'll give this a try and report anything out of the ordinary!
User avatar
OfficialYeen
 
Joined: 12 Feb 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby EricaOnline » Sat Mar 30, 2019 4:02 am

Hey guys. Lots to love about this mod - really appreciate you keeping it alive, Sumwunn!

I was just wondering: is there a way to switch map sets while maintaining character progression? For example, I've just played through the Master Levels using WadSmoosh as my iwad - is it possible for me to now jump into Doom 2 Map 01 without losing all my cool stuff?

Thanks!
User avatar
EricaOnline
 
Joined: 15 Mar 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby Forevener » Sat Mar 30, 2019 5:44 am

EricaOnline wrote:is it possible for me to now jump into Doom 2 Map 01 without losing all my cool stuff?

Hey! You could probably use the functionality of character saving/loading (in Doom RPG Options - Character).
Forevener
 
Joined: 20 Sep 2015
Location: Ufa
Discord: Forevener#3317

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby EricaOnline » Sat Mar 30, 2019 8:51 am

Forevener wrote:
EricaOnline wrote:is it possible for me to now jump into Doom 2 Map 01 without losing all my cool stuff?

Hey! You could probably use the functionality of character saving/loading (in Doom RPG Options - Character).


Ah. I actually tried that a few days ago and assumed I was attempting to make it do something it wasn't intended for because I got a "no character data found" error upon loading in a different map set... but it worked fine just now, so I suspect I missed the step of exiting the menu after hitting "save character" - I don't remember seeing the "Depositing Items" message last time.

Anyway, cheers Forevener!
User avatar
EricaOnline
 
Joined: 15 Mar 2019

Re: Doom RPG SE [unofficial, bugfix-ish]

Postby Forevener » Sat Mar 30, 2019 1:30 pm

EricaOnline wrote:I don't remember seeing the "Depositing Items" message last time. Anyway, cheers Forevener!

You are welcome! Yes, that takes some time, after you have pressed the button you have to exit the menu and wait in game while it's doing its stuff.
Forevener
 
Joined: 20 Sep 2015
Location: Ufa
Discord: Forevener#3317

PreviousNext

Return to TCs, Full Games, and Other Projects

Who is online

Users browsing this forum: atarumoroboshi18, BoneofMalkav and 9 guests