Pirate Doom! - House of Mojo 06/05/14

For Total Conversions and projects that don't otherwise fall under the other categories.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Korell » Mon Jul 23, 2018 7:08 am

Being as this thread has already been bumped I might as well add that the silent gatling gun and other sounds were due to an incompatibility with the FMOD sound system, but this was removed in later GZDoom versions and OpenAL plays the sounds correctly. I actually released a fixed version (before FMOD was removed, and with a number of fixes not just the sounds) on ModDB linked to the mod itself, so it can be found in the mod's downloads there.
Last edited by Korell on Tue Jul 24, 2018 10:25 am, edited 2 times in total.
User avatar
Korell
 
Joined: 28 May 2017

Re: Pirate Doom! - House of Mojo 06/05/14

Postby NightFright » Tue Jul 24, 2018 9:08 am

Thanks for pointing it out! Here is the direct link to latest version 1.8.3 for those that are too lazy to google it. ^^
User avatar
NightFright
 
Joined: 02 May 2008
Location: Germany

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Korell » Fri Aug 10, 2018 3:47 pm

I've just updated my fixed version to v1.8.4 as the activate OpenGL renderer messages issue has now been solved thanks to this thread: viewtopic.php?f=2&t=61609
The first two maps of the mod were using ACS scripts to check the value of the now defunct vid_renderer cvar and if it wasn't set to 1 (or not present at all as it is now defunct) then it would cause some silly messages to show up on screen, and then in the second map after the messages have finished it kills the player. This was originally because the mod required the OpenGL renderer on the old GZDoom versions, but the new versions of GZDoom work differently and don't have this cvar any longer. As such, all I've done is strip out the checks in the ACS scripts for the two affected maps (thankfully the ACS source is present in the original Pirate Doom v1.8).

New version can be found here: https://www.moddb.com/mods/pirate-doom/ ... v-18-fixed
User avatar
Korell
 
Joined: 28 May 2017

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Nottheman686 » Mon Dec 17, 2018 1:02 am

I love this mod, but ive got a problem with it recently and the opengl requirement. it's on but doesnt sense it... and so it's unplayable... HALP :|
Nottheman686
 
Joined: 21 Mar 2018

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Korell » Mon Dec 17, 2018 4:03 pm

Nottheman686 wrote:I love this mod, but ive got a problem with it recently and the opengl requirement. it's on but doesnt sense it... and so it's unplayable... HALP :|

I fixed this in my fixed version. Basically I just removed the check from the ACS script.
User avatar
Korell
 
Joined: 28 May 2017

Previous

Return to TCs, Full Games, and Other Projects

Who is online

Users browsing this forum: Brohnesorge and 7 guests