Aliens: Colonial Marines TC - FINISHED

For Total Conversions and projects that don't otherwise fall under the other categories.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Wed May 29, 2019 8:51 am

Hello

We downloaded the mod from here.

https://www.moddb.com/mods/acm-2014/downloads/acm-2014

This game is broken, it will completely lag out after 5-10 mins.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Thu May 30, 2019 12:36 pm

Can anybody provide the script to the skyclouds please?

Who in the right mind spawns 300+ clouds on a GZDoom application and not even test it? Did anyone even play this for more than 5 minutes?

Infact you didn't even need to play the game, just stand there for 5 mins and it will reduce to 1FPS.

What a waste of a good game, I tried my best, but without the specific strings for these clouds I cant fix this mess.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Deimos Anomaly » Thu May 30, 2019 3:43 pm

ZDL_800 wrote:Can anybody provide the script to the skyclouds please?

I will look again when I have time, but as I told, you can also remove the spawnpoint spots located on the skybox sector and problem solved. They can be replaced with static clouds and the results are just as good. That's what I did with my ongoing Aliens TC.

ZDL_800 wrote:Who in the right mind spawns 300+ clouds on a GZDoom application and not even test it? Did anyone even play this for more than 5 minutes?


Me? :roll: No need to be that rude, honestly. By now you are the only one with such problems. I beated ACM perhaps a month ago to refresh my memory on all the things I did there and all the things to improve and I didn't had any kind of problem or slowdown. Still is a good idea to get rid of such clouds.

ZDL_800 wrote:Infact you didn't even need to play the game, just stand there for 5 mins and it will reduce to 1FPS.
What a waste of a good game, I tried my best, but without the specific strings for these clouds I cant fix this mess.


Again you seem to be the only one with such issues. Calm down a bit, we will look again at this. As soon as I have time again I will check the files and get back to you via PM. Best regards!
User avatar
Deimos Anomaly
 
Joined: 27 May 2010
Location: Barcelona, Spain

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Thu May 30, 2019 5:31 pm

Sorry dude, I thought you did version 1 and someone else did version 2? I was reading a thread somewhere, about the rain and clouds were added to version 2 and it was modded?

Now I'm confused? Unless a very recent GZDoom update has broken the game, I tested this on 4 different PC's, one of them was a water cooled gaming PC nearly 5ghz and he said that I never seen a game lag so much on the unit?

I'm not the only person with this issue, someone else by the name of MetroidJunkie » Fri May 24, 2019 3:26 pm, on this thread said the same, Even on the Moddb page people say it lags too bad, I'm not the only one here with the highest respect, I do apologize for this.

Also when you said 'you can also remove the spawnpoint spots located on the skybox sector' I haven't the slightest clue how to implement that or where the script is even located to begin with? I researched as much as possible and I cannot see any comparisons to skyclouds anywhere in the games files? I don't have any foundation to work from.

When I implemented the Brutal Xeno blood to the Ai, I could see where everything was implemented, so it wasn't that difficult, but this is extremely difficult indeed.

Thanks again for helping us out, I'm sure the community would be eternally grateful if this could be fixed.

Thanks again.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Ozymandias81 » Fri May 31, 2019 2:33 am

Just open the console and type the following, pressing return for each line:

remove fogcloud_generator
remove fogcloud_v1
remove fogcloud_v2
remove fogcloud_v3
User avatar
Ozymandias81
Doom is a State of Mind... Out of Control.
 
Joined: 04 Jul 2013
Location: Mount Olympus, Mars
Github ID: Ozymandias81
Operating System: Windows Vista/7 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Fri May 31, 2019 11:31 am

Hello and thanks for the reply.

Unfortunately after the first input the console states, 'fogcloud_generator is not an actor class'?

Maybe its named something similar I'm not sure?

Thankyou for your help and hope to speak soon.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Ozymandias81 » Sat Jun 01, 2019 11:54 am

Okay it seems that I had a different version in the past and well the original version uses these actors:

remove nube1
remove nube2
remove nube3
remove nube4
remove cloudcaller
remove cloudfx

And also you can do this, but pretty sure it will break the map (if it gets removed)

remove mapspot
User avatar
Ozymandias81
Doom is a State of Mind... Out of Control.
 
Joined: 04 Jul 2013
Location: Mount Olympus, Mars
Github ID: Ozymandias81
Operating System: Windows Vista/7 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Sat Jun 01, 2019 2:53 pm

Thanks for the reply.

The new commands seem to be activated, you can see the statement removing 70+ actors from nube1 to 4, unfortunately the clouds are still moving across the sky? The command 'remove mapspot' seemed to increase the FPS but it still reduced to 1FPS as time went on, maybe 5 mins?

Nevertheless its still progress so thankyou very much for the updates much appreciated.

May I ask is it possible to go to the source and delete the scripts? Could they be other scripts apart from the decorate file that could have these parameters for the clouds and such? It would be great if we could load the maps in the editor and try and locate them. We might be able to find other factors which creates this lag issue?

This is such a great game it needs some attention. Would be epic if we could play this because the devs I believe are creating a new aliens game which is out of this world but going to take years from what the post stated, so just to play this in the meantime would be brilliant.

Thanks again.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Enjay » Sat Jun 01, 2019 4:03 pm

ZDL_800 wrote:The new commands seem to be activated, you can see the statement removing 70+ actors from nube1 to 4, unfortunately the clouds are still moving across the sky? The command 'remove mapspot' seemed to increase the FPS but it still reduced to 1FPS as time went on, maybe 5 mins?

Are you sure it's the clouds causing your slowdown? What made you decide it was them?

FWiW, I've played right through with no issues. That wasn't recently, but I fired it up yesterday and played for maybe 10 minutes: no hint of slowdown.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Sat Jun 01, 2019 4:44 pm

Hello

The dev said it could either be the rain or cloud particles but that's only a guess I assume.

Where did you download the mod from because the link on this forum is broken, did you download it from Moddb? How on earth you playing this game for more then 10mins? Did you kill any aliens on the 1st map? If you stand outside it breaks after 5 mins, if you progress through the map, by the time you see the first alien, it breaks? I cannot understand this? Are you using the recent version of GZDoom? Are you using ZDL launcher to load the mod list?

Thanks again.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Enjay » Sat Jun 01, 2019 5:48 pm

ZDL_800 wrote:Where did you download the mod from because the link on this forum is broken, did you download it from Moddb?

Yes. (and that version looks very much like the version I remember playing from a while back)

ZDL_800 wrote:How on earth you playing this game for more then 10mins?

Dunno, it just works. I just tried again. I played for 35 minutes. No real problems. I had vsync on and I did notice that in some outside areas when I was looking right across a large area my fps dropped as low as 53 but it was usually at the 60fps of my monitor refresh rate. It never went below 53 and when I looked away from the "problem" area, it went back to 60.

ZDL_800 wrote:Did you kill any aliens on the 1st map?

Yes, many. :twisted:

ZDL_800 wrote:If you stand outside it breaks after 5 mins, if you progress through the map, by the time you see the first alien, it breaks?

No and no. Not for me anyway. I played the entire map, start to finish.

ZDL_800 wrote:I cannot understand this? Are you using the recent version of GZDoom?

Yep, the last time I played I think it was with the 4.1.2 release. This time it was with a git build compiled yesterday.

ZDL_800 wrote:Are you using ZDL launcher to load the mod list?

Yes, but other loading methods worked just fine too.


One thing I did notice; near the end of the map, after hitting the switch in the yellow key room, the rain stopped. I assume that this is intentional. When that happened, the outside areas did seem smoother (60 fps everywhere).

As an aside, another thing I noticed, I think you can hear your flares all over the map. i.e. drop one and you can hear it burning from anywhere.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Aliens: Colonial Marines TC - FINISHED

Postby Enjay » Sat Jun 01, 2019 5:52 pm

I just had a quick look inside the scripts lump for E1M1. Script 500 is used to stop the rain. Maybe try typing

puke 500

at the console to see what happens if you haven't done so already.

There is also a script 500 for maps E1M2 and E1M3. All of these scripts have a comment "No Clouds".

Code: Select allExpand view
//NO CLOUDS=============================

script 500 (void)
{
thing_remove(51);
thing_remove(52);
thing_remove(53);
thing_remove(54);
thing_remove(55);
thing_remove(126);
}
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Aliens: Colonial Marines TC - FINISHED

Postby ZDL_800 » Sat Jun 01, 2019 8:31 pm

Thanks for the reply.

Enjay you must have some mega PC because I even tried on a friends unit with a 5GHZ CPU and it did the same lag. I downloaded the mod again, tested outside by just running about the first yard area, I didn't even enter the complex.

I did attempt to remove the rain by editing the script and when you type puke 500 into the console there was an error with 'actor invalid' so I tried the same command on the unmodded version what I just downloaded again and it works, I typed in the command when the FPS was just about the break around 5FPS, straight back to 60, no lag what so ever.

So it looks like the rain particles is the cause for the lag, I wonder if its some kind of memory leak, maybe its not deleting each rain particle? So its basically building up until it breaks?

I don't think its the clouds because after typing puke 500 the clouds are still there but don't seem to cause any issues? I will add the cloud script you provided to optimize the maps even more, seeing as we use darkdoom lighting, you cannot see the skyclouds anyway, so if we can remove them, the better. Thanks for the script.

I wonder if we could somehow replace the rain script with something more optimized? I believe this is the script for the rain but I'm not sure I did manage to reduce the rain particle distance but it still lagged.

Code: Select allExpand view
actor gotera 31007
{
   SPAWNID 255
   projectile
   Radius 1
   Height 1
   States
   {
   Spawn:
   BRS1 A -1
   Stop
   Death:
   BRS1 BCDEFGH 2
   Stop
   }
}


I created a thread 'Rain Effects' which many users have helped out in the quest to fix this issue, link here.

viewtopic.php?f=122&t=64774

I'm sure we can fix this now, remove the clouds, optimize the rain particles and I believe that would completely fix this game!

Thanks again.
User avatar
ZDL_800
 
Joined: 15 May 2019

Re: Aliens: Colonial Marines TC - FINISHED

Postby Enjay » Sun Jun 02, 2019 6:03 am

I just got through typing a reply to your PM but I thought it was probably better to post it here.
It seems as if you may have figured out some of the things that I was about to say but here goes:

ZDL_800 wrote:Hello and thanks for the help with the aliens mod.

May I ask regarding the script you provided? We placed it in the decorate file and it basically refused to load with an error?

We haven't got a clue where to place the script I'm afraid, sorry about this.

Thanks again.


Hi,

What you tried won't work because the code is not for DECORATE, it's for ACS. What's more, you don't need to add it, it's already in the mod. As I said, just open the console, type

puke 500

and the rain will stop.

The way that I found the script was looking inside the SCRIPTS lump of E1M1.WAD in the maps directory. To remind you about the script:

Code: Select allExpand view
//NO CLOUDS=============================

script 500 (void)
{
thing_remove(51);
thing_remove(52);
thing_remove(53);
thing_remove(54);
thing_remove(55);
thing_remove(126);
}


All that does is remove items with the tids listed (51-55 and 126).

I checked the map for you and tids 51-55 are just map spots. That means that there must also be a script that is spawning things at the map spots.

Sure enough, here's script 6
Code: Select allExpand view
script 6 open
//goteras
{
thing_projectile(random(50,55),255,0,0,-100);
delay(random(5,20));
restart;
}


What that does is spawn a projectile at map spot randomly chosen from tid 50-55. The projectile has spawn id 255 and if you check the DECORATE lump, the actor "gotera" (google tells me it's Spanish for "leak") has been given spawn id 255.

Interestingly, script 500 does not remove tid 50, so "goteras" keeps spawning at those map spots. Tid 50 is only used in small clusters as part of ceiling drip effects, so it may be deliberate to miss it out of script 500 or it may just be an oversight (I suspect the former, especially as similar effects are used in subsequent maps).

tid 126 is not a map spot, it is an ambient sound. Not too surprisingly, it's the rain sound. So, script 500 removes the sound too.

Anyway, the quick way to stop the rain is to type "puke 500" at the console as I said.

The longer way would be to open up the map in a map editor and search for all instances of tids 50,51,52,53,54,55 and 126 and remove them. It would be a pain though because there are hundreds of them. Then, as a belt and braces approach, remove script 6 from the scripts lump, remove script 500 and remove the call of script 500 (ACS_Execute(500,0,0,0,0);) from script 4, recompile the scripts and save.

A simpler version would be to change script 6 to read like this
Code: Select allExpand view
script 6 (void)


instead of
Code: Select allExpand view
script 6 open


That would leave script 6 and all the map spots in place but it would not run unless you deliberately run it via the console (puke 6).


Of course, if you just want to try using DECORATE to fix the problem, you could put something like this into a DECORATE file and load it after the rest of the mod:

Code: Select allExpand view
actor goterastop : gotera replaces gotera
{
   +NOINTERACTION
   States
   {
   Spawn:
      TNT1 A 1
      Stop
   }
}


That will replace the rain drop actor with one that removes itself 1 tic after spawning. That should speed things up for you.

(Or you could replace the goteras actor in the main DECORATE with something similar. But that does mean permanently altering the mod DECORATE file.)


The other maps are simpler. In both maps E1M2 and E1M3 script 500 reads like this:

Code: Select allExpand view
//NO CLOUDS=============================

script 500 (void)
{
thing_remove(35);
}


So, all it is doing is removing actors with tid 35. These are all "CloudCaller" actors and are placed in the skybox. There aren't that many of them so I'd be surprised if they were causing much difficulty but puking script 500 would remove them. For what it's worth, there are none of these "CloudCaller" actors on E1M1 so that's why changing their DECORATE had no impact on E1M1. The slowdown you are experiencing on E1M1 must be the because of the rain, not the clouds.

E1M2 also still has a script 3 like this:

Code: Select allExpand view
script 3 open
//Goteras
{
thing_projectile(random(50,55),255,0,0,-100);
delay(random(5,20));
restart;
}


So, it is also spawning raindrops on a regular basis. If you want to stop that, you'll need to remove the script (or rename it to a void one) or just remove all map spots with tids 50-55 in the map, or add a script to remove those tids like the script in E1M1 does, or use the DECORATE code that I provided above. However, there are far fewer map spots of this kind in map E1M2 and they are just used for random ceiling drips like tid 50 was in map E1M1. So, they are far less likely to be causing you problems.

E1M3 is basically the same as E1M2. Script 500 only removes clouds. There are still map spots where "goteras" are spawned (via script 25 this time)

Code: Select allExpand view
script 25 open
//Goteras
{
thing_projectile(random(50,55),255,0,0,-100);
delay(random(5,20));
restart;
}


but again, these are used fairly sparingly and are unlikely to be causing problems, but if you need to remove them, the solution would be much the same as for E1M2.


E1M4 has none of this because it's a much simpler map with none of these effects. So, it should run OK.


To sum up, I strongly suspect that your problems are caused by the rain effects on map E1M1. The rain can be stopped by typing "puke 500" at the console or doing something like using the DECORATE code that I posted above to stop the "gotera" actor. A more permanent solution would need you to edit the map and recompile ACS scripts. Maps E1M2 and E1M3 use the rain effect much more sparingly so it is less likely to be causing you problems. The clouds on these maps can be stopped my puking script 500 but the rain requires a bit more effort to edit them map and recompile scripts to stop the drip effects. E1M4 should require no changes at all.

The worst thing is (IMO) that the rain effect in E1M1 doesn't look great because you can see the rain coming down in bands every time the spawning script triggers.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Aliens: Colonial Marines TC - FINISHED

Postby Enjay » Sun Jun 02, 2019 6:21 am

While I was looking into the mod, I took a look at the flares actor. In two places the sound "flare/loop" is played

Code: Select allExpand view
A_PlaySound("Flare/Loop",7,1.0,1,-1)


I could be wrong but I think the last parameter (-1) is the attenuation for the sound. My guess is that -1 is being treated as ATTN_NONE and so the flares can be heard everywhere. I think the -1 should probably be changed to ATTN_NORM (or simply be removed) to use the defaults that have been set in SNDINFO for the sound.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

PreviousNext

Return to TCs, Full Games, and Other Projects

Who is online

Users browsing this forum: eclipse and 8 guests