Decals lit by Doom 64 style lighting

Moderator: GZDoom Developers

User avatar
SanyaWaffles
Posts: 764
Joined: Thu Apr 25, 2013 12:21 pm
Discord: SanyaWaffles#0950
Twitch ID: sanyawaffles
Operating System: Windows 11
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support
Location: Disappointment Island

Decals lit by Doom 64 style lighting

Post by SanyaWaffles »

I dunno if this is a bug or a missing feature but it appears manually placed decals are not lit by Doom 64 style sector lighting. I dunno if this is possible or in the pipeline. It'd be neat to be able to see that.

Use case: I'm using decals to display posters throughout the levels and they appear to be not affected by the doom 64 style lighting at all. Not even the 'things' light.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47968
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Decals lit by Doom 64 style lighting

Post by Graf Zahl »

That's because Doom64 colors are not 'light'. They are just colorized textures. They should be affected by the sprite color, though.
User avatar
SanyaWaffles
Posts: 764
Joined: Thu Apr 25, 2013 12:21 pm
Discord: SanyaWaffles#0950
Twitch ID: sanyawaffles
Operating System: Windows 11
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support
Location: Disappointment Island

Re: Decals lit by Doom 64 style lighting

Post by SanyaWaffles »

[imgur]https://imgur.com/SfiQkeu[/imgur]

Notice how the hand is affected but the decal isn't. Just to demonstrate.

It'd be neat if this could be fixed because right now decals kind of stick out a bit since I started changing the levels to use Doom 64 style gradients and lighting.
User avatar
SanyaWaffles
Posts: 764
Joined: Thu Apr 25, 2013 12:21 pm
Discord: SanyaWaffles#0950
Twitch ID: sanyawaffles
Operating System: Windows 11
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support
Location: Disappointment Island

Re: Decals lit by Doom 64 style lighting

Post by SanyaWaffles »

[imgur]https://imgur.com/ohsZeUl[/imgur]

An update.

I can confirm in latest builds this has been fixed due to this bug report. Mark this as "not needed" or move this to the bug reports and mark this as a duplicate.

Return to “Closed Feature Suggestions”