[HS] Textures dissapear when changing video mode

Bugs with GZDoom Vintage builds. Same rules apply as with all other bug reports fora.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

[HS] Textures dissapear when changing video mode

Postby drfrag » Tue Feb 13, 2018 2:30 pm

All versions affected (from 1.8.4 to latest SVN). With DTS-T.pk3 in MAP02 (has rain and fog) when changing video mode all textures dissapear and no more rain. Just changing to fullscreen triggers it.

https://www.doomworld.com/idgames/level ... wads/dts-t

Screenshot_Doom_20180213_184324.png
Last edited by drfrag on Mon Feb 19, 2018 7:08 am, edited 2 times in total.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Postby _mental_ » Mon Feb 19, 2018 5:55 am

Works fine for me using the latest code. Also tried 1.8.6, 2.2.0, 3.2.5 without an issue, fullscreen and windowed.
What's the hardware? Was something else loaded along with DTS-T.pk3?
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [HS] Textures dissapear when changing video mode

Postby drfrag » Mon Feb 19, 2018 6:14 am

No, actually happens with both intel and ati old GL 2 cards and only on maps with rain and fog so i don't think it's a driver problem. I started with default settings and just switching to fullscreen/windowed @640 makes the textures dissapear. May be i should try with an nvidia card.
Edit: HS stands for Holy Shit BTW.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Postby _mental_ » Mon Feb 19, 2018 6:25 am

I see. You should mention the legacy render path in OP. It's unrelated to particular hardware indeed.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [HS] Textures dissapear when changing video mode

Postby drfrag » Mon Feb 19, 2018 6:36 am

I didn't mention it since it happens on all versions even before the legacy render path existed.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Postby drfrag » Mon Feb 19, 2018 7:01 am

I've tried again and apparently only happens on MAP02, not on MAP03. Warping to any other map with the MAP command restores the textures.
I'm not sure about it affecting only the LRP.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: [HS] Textures dissapear when changing video mode

Postby Graf Zahl » Mon Aug 13, 2018 12:45 pm

Moved this because it no longer applies to the modern build.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [HS] Textures dissapear when changing video mode

Postby drfrag » Mon Aug 13, 2018 12:57 pm

And i deleted the attachment earlier today becouse i assumed it was not going to be fixed.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain


Return to Vintage Build Bugs

Who is online

Users browsing this forum: No registered users and 1 guest