Only weapon bobbing (no camera bobbing)

Remember, just because you request it, that doesn't mean you'll get it.

Moderator: GZDoom Developers

Only weapon bobbing (no camera bobbing)

Postby Derik » Thu Sep 05, 2019 12:10 am

Hello there,

After searching for nearly 5 hours how to make only the weapon moving while player is moving without having the whole screen bobbing i end up here as i have not been able to accomplish that.
I tried obviously the options in the GZDoom menu (i use latest version 4.1.3, well latest is 4.2.0 now it seems but it should be ok). I have tried my best at my Google skill (which is not bad ;p) and i found that : https://github.com/rheit/zdoom/blob/mas ... d_player.h but not sure if this would really do what I'm looking for. Nor do i know how to use/where to place the .h extension file (Google was a big let down for that). Even after unziping the gzdoom .pk3 i did not see a .h files folder.

It's the only thing that is missing for a better immersion.

Thank you for your assistance in this matter.




PS : I made this thread in the suggestion section as i wasn't sure this was relevant to put it in the general sub-forum. Feel free to move it wherever it would suite best if needed.
e: After some more considerations i was wondering if technically it would be feasible to have a separate volume slider just for the weapons inside GZDoom UI.
User avatar
Derik
 
Joined: 29 Dec 2017

Re: Only weapon bobbing (no camera bobbing)

Postby Kizoky » Sat Sep 21, 2019 4:26 pm

If you set Player.ViewBob to 0 it will disable that "camera bobbing"
For disabling things like "bobbing when falling onto a ground" you can just set Player.DeltaViewHeight to Player.ViewHeight

this way, only the weapon would bob
User avatar
Kizoky
I smell like gravity
 
Joined: 14 Nov 2011
Location: Around weirdos, I'm the biggest weirdo among them
Discord: Kizoky#0375
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia with Vulkan support

Re: Only weapon bobbing (no camera bobbing)

Postby Scile » Sat Nov 13, 2021 5:16 am

Kizoky wrote:If you set Player.ViewBob to 0 it will disable that "camera bobbing"
For disabling things like "bobbing when falling onto a ground" you can just set Player.DeltaViewHeight to Player.ViewHeight

this way, only the weapon would bob


Doesn´t work. It disables weapon bobbing as well.
Scile
 
Joined: 08 Mar 2019


Return to Feature Suggestions

Who is online

Users browsing this forum: No registered users and 0 guests