How can I stop SLADE from mass importing patches?

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.
User avatar
Acts 19 quiz
Posts: 12
Joined: Mon Nov 01, 2021 8:16 pm

How can I stop SLADE from mass importing patches?

Post by Acts 19 quiz »

How can I stop SLADE from mass importing patches from one WAD I have open to another one I'm editing?

To setup the scenario, the WADs I'm working on have new textures, in the format of TEXTUREx and PNAMES. PNAMES can have a mixture of patches that are in the new WAD, and ones I know will exist in the IWAD of choice. I often have a few different WADs opened, including the IWAD. With frequent updates to TEXTUREx, a common occurrence is that after saving changes to TEXTUREx, SLADE will try to 'help me out' by mass importing several patches from the IWAD into the PWAD. Some might find that helpful, but for me at least, it's undesirable. I know the patches I'm referencing in PNAMES aren't present in the WAD, but they will be when the PWAD is loaded on top of the expected IWAD. Several times, I've browsed through the lump directory and been surprised to find a slew of patches I wasn't aware were present, and had to delete them to clear out the clutter and bloat. Now having to perform such spot checks has turned into part of my regular SLADE editing routine, something I'm hoping to be able to remove from my regular routine. In the most egregious cases, I've found a bunch of patches—of all manner of dimensions and use of transparency—slapped between F_START and F_END as if they were common flats (they most definitely aren't). Not even custom IWADs are immune, for such cases when PNAMES and TEXTUREx reference sprites instead of patches (like the boss cube). The sprites end up duplicated in patches.

Is there a way to stop or change this unintended behaviour (don't import patches from open IWADs, but instead leave it in the modder's hands to make sure everything is in order) with a setting or something? I've looked all through SLADE's settings, including the "Advanced" section of SLADE Settings, but at a glance couldn't find anything that did what I was looking for.

Return to “Assets (and other stuff)”