Solved - Bad Lighting of Animated MD3 Models

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Solved - Bad Lighting of Animated MD3 Models

Postby Moebius » Fri Apr 08, 2022 11:12 pm

Riddle me this ENJAY, said the Old Salty Dog?
Or anyone else who may have experienced this.

1. Link is to an 8MB PK3 file containing a small recreation from my larger MAP. They're the airlock doors from Doom 3.
2. This is a Doom 2 MAP. It's only been run in GZDoom 4.7. Totally built using UDB, last updated in UDB 3.0.
3. OBJ models created from Doom 3 LWO models using MM3D 1.2.4 and MilkShape 3.0.
4. Animated MD3 model created using Blender 3.0 plus MD3 Exporter Add-On. I Imported individual OBJ models, created the animation, and exported it out of Blender.
5. Airlock on the left is constructed with static OBJ models, as well as OBJ models attached to polyobjects for the doors. It is lit and looks as expected.
6. Airlock on the right is constructed with static OBJ models, put has animated MD3 models as the doors. The static OBJ models are lit and look as expected. The animated MD3 doors are not.
7. Why? Do OBJ models "accept" light differently than animated MD3 models?
8. I exported an OBJ model from the animated MD3 model using MilkShape 3.0. It looks bad, too. So there's something in the MD3 model that is askew.

EDIT: I opened the exported OBJ model with WORDPAD and noticed no textures were listed for the different groups. I added the textures and reapplied all of them to their group. Reloaded everything and it now appears properly lit. The same did not work for the animated MD3 model.

EDIT 2: Since it appeared that something was amiss with the animated MD3 model I tried a couple of other apps. Now, If I open it in Maverick Model 3D the textures are there and the MD3 model is lit properly. So I ended up answering my own question. I'll have to go back and fix my other models. Blender still exports "crummy" MD3 files. It needs a better Add-on.


9. If someone wants the Blender file, I can upload it.
10. The reason I'd prefer using the animated MD3 models is that polyobject model attachment has been difficult to get right and it requires more script with time delays you have to mess around with. Boris' script sets up fine in one MAP and then I have to mess with it for hours in another. I also can't figure out how to implement more than two door models with his script.

I have other animated MD3 models that aren't taking light as expected. I didn't notice it initially, but with how bad the airlock doors are I went back and looked closely at them. They're darker than expected and the specular/normal isn't pronounce. I've been researching Blender for a possible solution with no progress yet.

https://drive.google.com/file/d/1GSAnkO ... sp=sharing
Moebius
 
Joined: 28 Jan 2021

Re: Solved - Bad Lighting of Animated MD3 Models

Postby Moebius » Sat Apr 09, 2022 3:33 am

I apologize for a post that I ended up resolving shortly after. But it was the writing up of the post that provided me with a direction to the solution.

Of the five animated MD3 models I have, three were messed up straight out of Blender. The other two were just fine. So there is something I did constructing the model in Blender that's different. I have no idea what that would be.

The solution was to open up the problem animated MD3 models in Maverick to see if the textures were showing on the model in the 3D window or if just the names were there and the textures showed as Red X.

I fixed the three that had the Red X texture and resaved them. All three are lit properly now. However, if I open one specific file again it still shows Red X. I don't know why.

In my case I'm either not setting up my imported OBJ models in Blender the same way. Or I've already done something different with the original OBJ file that doesn't import.
Moebius
 
Joined: 28 Jan 2021


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests