Little help with gimp?... ^^'

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Little help with gimp?... ^^'

Postby Ravick » Sun Nov 07, 2021 8:05 pm

Hi there.

Well, it is my first time trying to seriously use Gimp, so maybe it is a very "noobish" problem. What I want to do is to mix the Doom's FLAT20 patch with a translucid version of FWATER1 (and so on) and also with a 90º rolled variant of FWATER1. I mean, I want to mix these 3, and make it looks like there is a small water layer over the tile floor:


++

I start by opening the FLAT20 in Gimp, and them adding the two FWATERs as layers with some translucid. While I'm looking at it in Gimp, it looks just like what I want:



However, when I try to export this work as png, or even just to combine (Ctrl+M) all the layers, this is what I get:



What am I doing wrong here? And how can I save the image I see at Gimp as it looks? (Please don't tell me to put 0% zoom at it and print the screen. I've got this reply today already D':)

Thanks in advanced. :)
User avatar
Ravick
Do what thou wilt, since you don't bug the hell out of me!
 
Joined: 22 Aug 2010
Location: Tubarão, Brasil

Re: Little help with gimp?... ^^'

Postby Logan MTM » Sun Nov 07, 2021 8:26 pm

Esquece as camadas e só exporta a bagaça toda!
Na dúvida me passa um zap!
Hue Hue BRs :mrgreen:

1.PNG


Basicamente: Imagens > Modo > RGB
You do not have the required permissions to view the files attached to this post.
User avatar
Logan MTM
I can see you...
 
Joined: 16 Jan 2006
Location: Rio de Janeiro - Brazil

Re: Little help with gimp?... ^^'

Postby Caligari87 » Mon Nov 08, 2021 10:55 am

It looks like the image is getting exported with the palette restrictions. Probably because you started by opening a paletted image (FLAT20) so it stays with that palette. Check under the "Image > Mode" menu and make sure it's set to "RGB" if you want truecolor.

Not sure about the layer merging issue, but try right-clicking on some layer in the list and choosing "flatten image" rather than merging down (merging down can cause some unexpected results when you have multiple layers with different blending modes). Note that exporting to PNG flattens your image anyway so this isn't strictly necessary in every case.
EDIT: Actually I just realized this is also probably because of the palette issue. It blends the layers in truecolor but any given pixel in a layer can still only be a palette color, so the color range gets reduced when you combine layers.

8-)
User avatar
Caligari87
I'm just here for the community
User Accounts Assistant
 
Joined: 26 Feb 2004
Location: Salt Lake City, Utah, USA
Discord: Caligari87#3089
Github ID: caligari87
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Little help with gimp?... ^^'

Postby Ravick » Mon Nov 08, 2021 7:29 pm

Thank you a lot, guys! :D
User avatar
Ravick
Do what thou wilt, since you don't bug the hell out of me!
 
Joined: 22 Aug 2010
Location: Tubarão, Brasil


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 2 guests